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Úvod

V dnešní době moderních způsobů komunikace, v době, kdy se lidé domlouvají
mobilními telefony a objednávají si přes internet víno, knihy nebo videa, chce být snad
každý člověk, který alespoň lehce pronikl do světa informačních technologií, „na
vrcholu“, v centru dění. Pro určitý okruh lidí je takovým centrem skutečně World Wide
Web.

Určitě každý, kdo přišel do styku s tímto médiem zatoužil vystoupit zde a dát na
obdiv své virtuální „já“, realizovat se, případně si udělat celosvětovou „bezplatnou“
reklamu. Setkávají se zde jednotlivci, skupiny, firmy, ale mnoho dalších nepopsatelných
subjektů, které se snaží získávat, ale i naopak podávat informace, diskutovat,
polemizovat, nabízet atd. Internet se tedy stal denní potřebou miliónů lidí.

 Pokud trochu sledujeme vývoj internetu a zvláště pak jeho služby World Wide Web,
uvědomujeme si, že i přes svou závratnou rychlost, se kterou nás spojuje se světem,
směřuje k ještě rychlejšímu a efektivnějšímu přístupu ke konzumentovi. Dnešní WWW
stránky jsou často natolik esteticky a funkčně tvořeny, že se jich nezalekne ani sváteční
uživatel počítače. Dokonce by se někde mohl cítit velmi příjemně, neboť si připadá jako
před supermoderním televizorem, se kterým vede dialog.

Mluvím tedy o plně mediálních stránkách určených pro běžného návštěvníka,
kombinujících text s videem, animacemi a hudbou. Do nedávné doby byly takové
stránky pouhým snem, neboť pokud některé vyjímky existovaly, byly značně omezeny
rychlostí internetu nebo spíše technologií. Animace byly zastoupeny pouze trhaně
animovanými obrázky (mám na mysli animované Gif soubory), interaktivita pak
tvarově chudými tlačítky.

Dnes se na šíření WWW v podstatě podílí i sami řadoví uživatelé, dokonce i ti, kteří
o programovacích jazycích nevědí zhola nic. Takový komfort, kdy stránku navrhujeme
jednoduše, jakobychom ji kreslili na papír, nám dodává i společnost Macromedia se
svými produkty. Díky nástrojům Flash, Fireworks a Dreamweaver a díky jejich
technologii jsme schopni vygenerovat dokument s úchvatnými a rychlými animacemi,
originálními tlačítky a hlavně unikátním designem, dokument, kterým oslovíme i toho
nejzarytějšího odpůrce internetu.
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Macromedia Flash 5

Macromedia Flash je velmi efektní nástroj pro tvorbu interaktivních animací
a dokumentů určených hlavně pro webovské prostředí internetu. První verze programu
byla představena v roce 1996, jako editor se zcela novým přístupem k tvorbě grafiky
a animace pro world wide web. Flash totiž pracuje na bázi vektorové grafiky. Z její
podstaty vyplývá malá velikost vyprodukovaných obrázků a hlavně animací, které  jsou
potom velmi rychle přenášeny přes internet.

Hlavní výhodou Macromedia Flash je možnost tvorby plně interaktivních animací.
Toho však nelze dosáhnout pouze grafikou a proto Flash obsahuje svůj vlastní jazyk,
kterým je animace a její interaktivita řízena. Jmenuje se ActionScript a ve svých
začátcích byl velmi prostý. Nyní obsahuje mnoho funkcí a operací, se kterými je
uživatel schopný vytvořit kompletní stránku bez použití HTML kódu nebo JavaScriptu.
To ale neznamená, že by technologie Flash konkurovala HTML jazyku, který je dnes
nejrozšířenější. Spíš se jedná o dvě paralely, kde HTML je se svými odrůdami XHTML,
VRML apod. tradiční přístup vhodný pro tvorbu statických textových prezentací
pro rychlý přenos a přehlednost informací. Flash je pak dnes relativně novou a sílící
metodou umožňující překonat hranice animovaných Gifů a vytvářet zcela originální
graficky orientované www stránky. Tyto dva způsoby tvorby je možné  hlavně velmi
efektně kombinovat a dospět k velmi užitečnému kompromisu, kde běžný text doplňují
působivé interaktivní animace.
ActionScript je dnes schopen pracovat i s proměnnými jako jiné jazyky a používat je
např. v kombinaci s CGI skripty.

Animace jsou ve Flashi kresleny obrázek po obrázku (frame by frame) a je možné je
doplnit zvukem (v Macromedia Flash 4 a 5 i v MP3 formátu) a interaktivitou v podobě
tlačítek, menu, klikmap atd.

Nové dokumenty jsou ukládány do několika formátů. Formát FLA je zdrojovým
kódem a má význam pouze pro tvůrce, který jej může přímo editovat. SWF je formát,
do kterého Fireworks ukládají komprimovaný dokument přímo pro použití v internetu.
Do souborů SWF Fireworks neukládají přímo celou animaci, ale pouze data, která jsou
nezbytně nutná pro interpretaci Flash Playerem, který je běžnou plug-in součástí
prohlížečů Microsoft IE a Netscape (pokud není nainstalován, je vždy po navštívení
libovolné Flash stránky nabídnuto stažení tohoto přehrávače zdarma z oficiální stránky
fy Macromedia).

Flash dokumenty je také možné exportovat (uložit) v podobě EXE souboru a
spouštět je přímo z disku, čímž částečně nahrazují produkty multimediálního editoru
Macromedia Director, určeného pro interaktivní CD-ROM. Ten vytváří dokumenty
typu Shockweave a na internetových stránkách je také rozšířen.
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Vzhled Macromedia Flash 5

Už od samého začátku je patrné, že je prostředí Flash uzpůsobeno pro návrh animace.

Vzhled Macromedia Flash 5

Veškerá pomocná okénka a panely můžeme libovolně přesouvat a kombinovat. Je
možné např. libovolnou záložku panelu uchopit a přetáhnout ji do panelu jiného.
Všechna okénka otvíráme v menu Window>Panels>... nebo všechna rychle zavíráme
položkou Window>Close All Panels. Pokud chceme zachovat pro příště vlastní
rozmístění panelů, zvolíme před ukončením programu položku Window>Save Panel
Layout..., kam můžeme např. pod své jméno uložit aktuální nastavení. To při novém
spuštění Flash 5 můžeme opět obnovit (Window>Panel Sets>...).

Atypickou součástí obrazovky je především časová osa s panelem vrstev, kde
probíhá hlavní práce při kompozici animace. Skrýt i z obrazit ji můžeme v menu
View>TimeLine, volnì pøesuvná je jako všechny ostatní panely.

Pracovní plochu zobrazujeme v menu View>Work Area a náhled na ni zvětšujeme
resp. zmenšujeme nástrojem Lupa v panelu nástrojů, nebo přímo v menu View>Zoom
In/ Out/ Magnification>...
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Otevření dokumentu

Po spuštění Flash se automaticky otevře nový dokument a zobrazí se jeho scéna.
To znamená, že můžeme rovnou začít tvořit novou animaci. Pokud je ale pracovní
plocha prázdná máme na výběr několik způsobů jak dokument otevřít:
• Založením nového souboru (File>New) — vždy se otevře nový dokument podle

implicitních (přednastavených) atributů.
• Otevřením existujícího souboru (File>Open...) — otevře se dialogové okno, kde

vybereme požadovaný soubor typu FLA, SWF, SPA nebo SSK.
• Přetažením souboru metodou Drag&Drop — uchopíme soubor jednoho ze čtyř

podporovaných formátů např. v průzkumníkovi a přetáhneme na pracovní plochu
Flashe.

Macromedia Flash 5 dovoluje otevření několika dokumentů najednou.

Uložení dokumentu

Macromedia Flash podporuje ukládání souboru pouze ve formátu FLA. Slouží pouze
pro dočasné uložení a následnou úpravu opět v prostředí Flashe. Po zvolení menu
File>Save nebo File>Save As... se otevře dialogové okno, kam zadáme jméno souboru
a jeho umístění v adresářové struktuře.

Pokud bychom chtěli dokument uložit do souboru jiného podporovaného formátu,
použijeme funkci EXPORT (viz kapitolu Export dokumentu).

Nastavení dokumentu
Vlastnosti dokumentu obvykle nastavujeme hned na začátku práce v dialogu
Modify>Movie..., kde upravujeme následující atributy:
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Vektorová grafika ve Flashi

Veškeré kreslení ve Flashi probíhá ve vektorové grafice. Jedná se tedy o objektově
orientovaný editor, kde objektem chápeme každý samostatný bod, samostatnou úsečku,
křivku, seskupené objekty, ale i celé importované bitmapové obrázky (viz kapitola
Import souborů).

Pro pochopení vektorové grafiky a kreslení v ní je vhodné prostudovat uživatelskou
příručku Macromedia Fireworks 3, která je součástí této práce. Zvládnutí kresby
samotné je velmi důležité pro tvorbu nejen internetové statické grafiky, ale právě
i animovaných dokumentů Flashe. Editování vektorových prvků je ve Flashi velmi
podobné. Pouze nenabízí tolik možností jako plnohodnotný grafický editor, ale to není
nutné, neboť disponuje kvalitním Importem rozeznávajícím mnoho druhů vektorových
i bitmapových formátů (viz kapitola Import souborů) a vestavěnou funkcí Trace Bitmap
(Modify>Trace Bitmap), převádějící více či méně úspěšně bitmapový obrázek
na vektorové objekty.

Základní termíny pro pochopení následujících kapitol jsou:
• bod — jeden jediný bod
• cesta — libovolná nepřerušená úsečka, křivka (uzavřená — začátek a konec jsou

jeden a tentýž bod, otevřená — začátek a konec jsou dva různé body)
• kostra — je každá cesta objektu
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Kreslení

V této kapitole stručně popíši, jak ve Flashi kreslit a editovat vektorové objekty.
K těmto účelům používáme panel nástrojů (Window>Tools), kde kliknutím volíme
jednotlivé nástroje. Jejich vlastnosti lze nastavit externě v některých dalších panelech,
nebo přímo ve dvou sekcích nástrojového panelu — sekce barev (Colors) a atributů
(Options).

Panel nástrojů — Tools

Line, Oval a Rectangle Tool
(linka, ovál a obdélník)
Tyto nástroje kreslí základní tvary.
• Vybereme nástroj a nastavíme druh linky a výplně (výplň nelze nastavit

pro jednoduchou linku — viz panel Stroke a Fill).
• Stisknutím tlačítka myši a tažením kreslíme objekt.
• Poklepáním na nástroj Rectangle nastavujeme zaoblení rohů obdélníku, stejnou

vlastnost měníme i přímo při kreslení klávesami šípka nahoru a dolů nebo v panelu
Options, který je součástí panelu nástrojů

• Držením klávesy SHIFT — nástroje Oval a Rectangle kreslí přesné kružnice
a čtverce, Line kreslí kolmé nebo vodorovné linky.

• Držením klávesy ALT — nástroj Line se natáčí přesně po 45°.

Při kreslení čar se po přiblížení ke konci jiné linky zobrazí u kurzoru kolečko, které
symbolizuje možnost přesného navázání. Je však nutné zatrhnout volbu přichytávání
objektů (View>Snap To Objects)
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Pen Tool
Perem jsme schopni vytvářet dokonalé křivky či lomené čáry s uzlovými body. Tyto
body přidávat nebo naopak ubírat. Pokud pouze klikáme perem na různá místa plátna,
vytváříme lomenou čáru, kterou zakončíme kliknutím do posledního bodu nebo
kliknutím do bodu počátečního, čímž vytvoříme uzavřenou cestu.

Je však možné nakreslit i ladnou křivku tím, že v počátečním bodě stiskneme tlačítko
myši a pohybem vytvoříme pomyslnou vodící přímku (ta se nám zobrazuje pouze
dočasně), nebo spíše počátek křivky. Po kliknutí v jiném zvoleném bodě můžeme
vybrat cílový bod nebo stisknutím tlačítka a tahem novou křivku více prohnout. Křivku
můžeme buď dále rozvíjet nebo zakončit stejným způsobem jako lomenou čáru.

Pencil Tool (tužka)
Tužku používáme stejně jako v praktickém životě, ve Flashi hlavně k rychlému kreslení
objektů „od ruky“.
• Vybereme nástroj Pencil a nastavíme druh linky a výplně (výplň nelze nastavit pro

jednoduchou linku — viz panel Stroke a Fill).
• Vybereme kreslící mód v Options pod panelem nástrojů, který definuje stupeň,

jakým bude námi načrtnutá křivka převedena do vektorové podoby:

∗ Staighten po dokreslení linky upravuje náš rukopis geometricky
∗ Smooth upravuje náš rukopis ladně
∗ Ink upravuje nejméně, ponechává věrnější rukopis
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• Klávesa Shift usnadňuje kreslení přesných vodorovných a kolmých úseček

Brush Tool (štětec)
Se štětcem pracujeme téměř stejně jako s tužkou. Navíc obsahuje několik specialit.

• Vybereme nástroj Brush Tool a nastavíme druh linky a výplně (výplň nelze nastavit
pro jednoduchou linku — viz panely Stroke a Fill).

• V Options klikneme na ikonu Brush mode a vybereme jeden z následujících typů
překreslování:

∗ Normal — překresluje všechny linky a výplně ve stejné vrstvě.
∗ Behind — kreslí pouze na prázdné plochy v pozadí.
∗ Selection — Kreslí pouze ve vyselektované výplni (na obrázku pouze modrá

oblast žárovky).
∗ Fill — překresluje pouze výplňe objektů.
∗ Inside — překresluje pouze výplň, ve které jsme začali malovat, štětec nemá vliv

na žádné jiné objekty

     Originál             Normal     Behind     Selection         Fills         Inside

• Vybereme velikost a tvar štětce z Options, případně barvu.
• Držením Shift kreslíme kolmé a vodorovné tahy.

Macromedia Flash 5 podporuje tablet, proto je možné u některých modelů využít změnu
šířky štětce v závislosti na tlaku pera na podložku.

   Tlačítko Lock Fill v Options zamyká výplň viz  nástroj Fill Bucket Tool.
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Ink Bottle Tool (vlastnosti linky)
Tímto nástrojem měníme dodatečně barvu, šířku a styl linky nebo okraje výplně, na
které ukážeme. Systém dodatečného doplňování vlastností linky ušetří čas oproti
nastavování atributů pro každou zvlášť.

Stačí zvolit nástroj Ink Bottle a nastavit vlastnosti linky v panelu Stroke a pak už
můžeme klikat na jednotlivé linky či výplně a měnit jejich vzhled.

Panel Stroke

V panelu Stroke (Window>Panels>Stroke) nastavujeme vlastnosti linky, kterou
budeme kreslit. K dispozici je několik předpisů včetně vlastního definování vzhledu
linky (volba Custom v menu panelu).

Panel Stroke pro úpravu vzhledu linky

Paint Bucket Tool (výplň)
Nástroj slouží pro zaplňování více méně uzavřených oblastí. Ohraničené objekty
můžeme vyplňovat barvou, stupňovanými odstíny (gradient) a bitmapovými obrázky.

Options Paint Bucket Tool:

   Lock Fill zajišťuje provázání výplní několika objektů. Použití je následující:
Vyberem nástroj Výplň nebo Štětec a zvolíme bitmapovou nebo stupňovanou výplň (viz
panel Fill). Pokud chceme provázat výplň již hotového objektu, vybereme nástroj
Dropper Tool (kapátko) a klikneme do vybrané výplně. Pak stačí klepat do ostatních
objektů, které se začnou vyplňovat totožně.
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   Transform Fill slouží k dodatečné úpravě výplně. Klikneme-li po výběru této
volby do bitmapové nebo gradient výplně, zobrazí se ovladače, kterými tahem výplň
tvarově modifikujeme. Při modifikaci provázaných výplní (např. funkcí Lock Fill)
upravujeme všechny současně.

Ovladače výplně (Bitmap a Radial Gradient)

Panel Fill

Druh výplně je velmi snadné nastavit z panelu Fill (Window>Panels>Fill). Pokud jsme
pøedem oznaèili libovolnou oblast, nastavení se v této oblasti okam�itì projeví. Jinak
staèí zvolit Paint Bucket Tool a kliknout na po�adovanou výplò. Pop-up menu panelu
nabízí pět typů:
• None je průhledná výplň.
• Solid je výplň jednou barvou. Z palety, která se zobrazí po stisknutí malého políčka

pod pop-up menu, vybereme barvu, nebo ji kapátkem načteme z libovolného místa
obrazovky. V okénku nad paletou je možné zadat její hexadecimální kód.

• Linear Gradient (stupňovaná) vyplňuje objekt lineárně přecházejícími barevnými
valéry. Ten je možné složit až z osmi barev. Na barevném obdélníku gradient
definujeme přidáváním barevného ovladače (kliknutím těsně POD obdélník) a jejich
ubíráním (odtažením ovladače od obdélníku). Samotné ovladače kliknutím označíme
a dalším kliknutím do barevného obdélníku přesouváme na požadované místo. Barvu
ovladače měníme z palety stejně jako u výplně Solid. Vytvořený gradient je možné
uložit stiskem malé diskety. Okamžitě je přenesen do palety výplně, která je součástí
panelu nástrojů.
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 Panel Fill, kde upravujeme výplň — Radial Gradient
 
• Radial Gradient funguje stejně jako Lineární, barvy jsou uspořádány do kružnic.
• Bitmap vyplňuje libovolným bitmapovým obrázkem. Panel zobrazuje obrázky, které

můžeme vybrat a ihned aplikovat použitím Paint Bucket Tool. Obrázky do seznamu
vkládáme tak, že importujeme do Falshe obrázek ze souboru a aplikujeme na něj
funkci Break Apart (viz stejnojmennou kapitolu). Ten pak můžeme okamžitě
z plochy odstranit, neboť se automaticky zapíše do knihovny výplní.

Je nutné podotknout, že pokud aplikujeme výplň na libovolný objekt, obrázek nebo
gradient se nakopírují vedle sebe po celé ploše plátna. Viditelné budou pouze
v objektech, kde jsme tuto výplň vložili. Pokud výplň dále nemodifikujeme, při dalším
„rozlití“ stejné výplně se nakopírovaný podklad pouze odkryje.

Eyedropper Tool (kapátko)
Kapátkem kopírujeme vlastnosti čar a výplní. Pokud klikneme kapátkem na linku,
nastaví se podle ní barva štětce a vlastnosti v panelu Stroke. Klikneme-li na výplň
nastaví se barva výplně a vlastnosti panelu Fill. Okamžitě po vybrání kopírovaného
objektu je kapátko nahrazeno nástrojem Ink Bottle Tool resp. Paint Bottle Tool a my
můžeme rovnou okopírované nastavení aplikovat na jiné objekty.

Při kopírování výplňe je vždy automaticky zapnuta funkce Lock Fill provazující
jednotlivé objekty (viz Paint Bucket Tool).

Označování a úprava objektů

Označování objektů je velmi důležitá funkce, která je základem veškeré kresebné práce
ve Flashi. Je reprezentována nástroji Arrow, Subselect a Lasso Tool.
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Na začátku je nutné podotknout, že grafika v Macromedia Flashi je jakýmsi
hybridem mezi grafikou bitmapovou a grafikou vektorovou. Samozřejmě větší podíl
mají vektory, ale ty oplývají některými vlastnostmi bitmap.

Pokud se totiž pohybujeme a kreslíme v jedné vrstvě (viz kapitola Vrstvy), potom
jako bychom kreslili na jeden papír a objekty v něm nakreslené mohli překreslit jinými,
což je v běžných vektorových editorech nemyslitelné. Např. nakreslíme obdélník a přes
něj další, spodní obdélník bude z části překreslen. Zároveň můžeme označovat a vybírat
pouze části objektů k dalšímu zpracování.

Skupiny

Proto je vhodné jednotlivé celky (např. domeček) seskupovat (Modify>Group)
a pracovat s nimi jako s jedním objektem. Při dalším kreslení si tak takový obrázek
nemůžeme poškodit překreslením.

Poklepáním na skupinu se přepneme do módu editace skupiny, kde upravujeme
zvlášť jednotlivé prvky. Pod hlavní ikonovou lištou se vedle jména scény objeví jméno
skupiny, kterou zrovna editujeme. Zpět do běžného módu se přepneme klepnutím na
název scény.

Tento způsob editace skupin je velmi výhodný, protože není před editací nutné
skupiny rozdělovat (Modify>Ungroup) a pak zase jednotlivé prvky slo�itì vybírat pro
seskupení.

Select Tool (šipka, ukazovátko)
Ukazovátko je velmi mocný nástroj pro označování (vyselektování) a práci s objekty.
Ty můžeme upravovat, vybírat jejich části, přesouvat a jinak modifikovat.

Označování objektů

Můžeme vybírat třemi způsoby:
• Pravoúhlým ohraničením — jako když chceme nakreslit čtverec ohraničíme

požadované objekty. Do výběru bude zahrnuta pouze tato oblast, tedy pouze části
objektů.
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• Kliknutím na objekt — klikneme na libovolný objekt a bude vybrána výplň nebo část

linky do lomu nebo přerušení.
• Dvojklikem na objekt — pokud klikneme na výplň označíme celý objekt i

s okrajovou linkou, pokud na linku, označíme souvislou nepřerušenou linku.
• Podržením klávesy Shift — spolu s kliknutím přidáváme/ubíráme další objekty

do/z výběru.

Označenými objekty pak můžeme pohybovat tažením, nebo je v menu Edit kopírovat
(Copy/Paste),  mazat (Cut), vkládat na stejné místo (Paste In Place), volžit jako
speciální objekt (Paste Special...), duplikovat (Duplicate — důležité pro vytváření
nových symbolů viz Symbol a jeho instance). Vybrat můžeme i všechny objekty na
scéně (Edit>Select All) nebo zrušit veškerý výbìr (Edit>Deselect All).

Viditelnost označení můžeme ovlivnit zvolením View>Hide Edges, což zamezí
zobrazování vyselektovaných linek.

Přichytávání objektů

Pro snadnější umisťování objektů na plochu v závislosti na poloze ostatních objektů je
k dispizici volba Snap To Objects v Options (View>Snap To Objects).

   Pokud nastavíme tuto funkci, budou se objekty automaticky při přesunu
nastavovat do co nejvhodnější polohy k objektům ostatním, nebo se budou přichytávat
k pomocné mřížce (View>Grid>Show Grid) nebo vodítkům (View>Guides>Show
Guides). Vodítka nastavujeme tažením pravítka (View>Rulers) na scénu.

Změna tvaru objektu

Po ukázání šipkou na neoznačenou linku objektu se vedle objektu objeví malý růžek
pokud ukážeme na vrchol objektu. Pokud ukážeme na střed linky, ukáže se malý
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oblouček. Pak můžeme stiskem a tahem myši měnit polohu vrcholu nebo měnit tvar
linky resp. křivky.

Pokud součástí objektu je i výplň, přizpůsobuje se nově upravenému okraji objektu.

Podržením klávesy Ctrl můžeme uprostřed přímky přidat ostrý vrchol.

Úprava proporcí objektu

Libovolný označený objekt můžeme zvětšovat nebo zmenšovat (Modify>Transform>
Scale) nebo natáčet (Modify>Transform>Rotate). Vždy se zobrazí čárkované
ohraničení objektu a malé čtverečky resp. kolečka, což jsou ovladače, kterými funkce
ovládáme. Střed otáčení objektu měníme funkcí Modify>Transform>Edit Center.... Obì
funkce lze rychle zapínat v panelu nástrojù — Options.

    

Další úpravy objektu jako jsou překlápění (Flip H/V), pravoúhlé otáčení (Rotate 90°)
nebo numerické nastavení (Scale and Rotate...) jsou také dostupné v menu
Modify>Transform nebo v panelu Transform (Window>Panels>Transform).
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Panel Transform pro tvarovou úpravu objektu

Zarovnávání tvarů

V Options nástroje Arrow jsou k dispozici další dvě funkce Smooth a Straighten
(Modify>Smooth/Straighten). Obě slouží pro zjednodušení křivky.

   Smooth označenou křivku zaobluje a uhlazuje

   Straighten křivku napřimuje

Manuální Smooth můžeme nastavit v menu (Modify>Optimize).

Další úpravy objektu

Hrany vytvořeného objektu můžeme převádět na objekty, které se budou chovat jako
výplň (Modify>Shape>Convert Lines To Fills).

Expand Fill ze stejného menu zvětšuje nebo zmenšuje objem výplně po obvodu
o náležitý počet pixelů.

Soften Fill Edges rozostřuje hrany výplně.

Subselect Tool (podvýběr)
Slouží k detailní úpravě hran objektů a jejich výplně.
• Zvolíme nástroj Subselect a klikneme na libovolný objekt (pokud upravujeme výplň

je nutné kliknout na její okraj).
• Pokud je vedle kurzoru černý čtvereček, kliknutím objekt vybereme a tím zobrazíme

jeho uzlové body, nebo tahem přesuneme jako nástrojem Arrow.
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• Bílý čtvereček signalizuje, že vybereme jeden konkrétní bod, který tahem můžeme
přesunout. Pokud je bod součástí křivky, můžeme upravovat jeho ovladač a tím
měnit tvar křivky.

Lasso Tool (laso)
Lasem vybíráme objekty nebo oblast formou ohraničení buď volným tvarem, nebo
polygonálním tvarem po zaškrtnutí ikony Polygon Mode v Options.

Dvojitým kliknutím ukončíme nastavování výběru.
V Options tohoto nástroje je další alternativa:

  Magic Wand (magická hůlka) funguje při editaci bitmapy, na kterou byla
aplikována operace Modify>Break Apart a kde vybírá souvislou oblast odpovídjící
barevně bodu, na který jsme klikli.

  Magic Wand Properties otvírá dialogové okno, kde nastavujeme barevnou
toleranci (1—200, 0 znamená, že budou vybrány pouze pixely naprosto stejné barvy)
a způsob rozostření okrajů výběru.

Umísťování objektů — panel Align

Označené objekty (více jak jeden) můžeme stavět snadno a rychle do vzájemné polohy
v panelu Align (Window>Panels>Align).
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Panel Align pro rozmístění objektů do vzájemné polohy

Pokud zatrhneme tlačítko To Stage objekty budeme zarovnávat v závislosti na plátně,
v opačném případě budou sestavovány pouze podle původního rozestavení objektů.

Nastavení Barev

Barvy pro jednotlivé nástroje nastavujeme přímo na panelu nástrojů v sekci Color.
Kliknutím do políčka vedle malého štětečku nastavujeme aktuální barvu štětce resp.
pera. Vedle ikony kyblíku nastavujeme barvu výplně.

Okno pro nastavení barvy výplně nebo linky

Paleta, která se otevře je kopií panelu Swatches (Window>Panels>Swatches), kde
vybíráme barvy přímo z barevného vzorníku. V Macromedia Flash je vestavěna paleta
Web 216, což je bezpečná paleta pro věrné zobrazování odstínů na různých systémech
provozovaných na internetu. Palety však můžeme importovat ze souboru nebo
rozšiřovat stávající o vlastní barvy.



Macromedia Flash 5

33

Ruční výběr individuální barvy se provádí skrz panel Mixer. Tam můžeme barvu
nadefinovat i numericky podle tří předpisů a přidat do palety v panelu Swatches.

RGB — barva složená ze tří složek R—červená, G—zelená a B—modrá.
HSB — barva složená podle optických vlastností H—odstín, S—sytost, B—jas.
HEX — hexadecimální (v šestnáctkové soustavě) vyjádření RGB.

Panel Mixer pro definici vlastního barevného odstínu

Psaní textu

Text Tool
V Macromedia Flash 5 píšeme text přímo na scénu. Klikneme-li na plátno nástrojem
Text, zobrazí se malý obdélník, do kterého rovnou píšeme. Ten se při psaní automaticky
velikostí přizpůsobuje délce i řádkování. Psaní zrušíme kliknutím mimo tento obdélník,
nebo zvolením jiného nástroje z panelu nástrojů.

Při psaní, je vždy zobrazen v pravém horním nebo dolním rohu rámečku ovladač,
kterým upravujeme velikost okna:

Tahem automatického ovladače změníme rámeček na fixní, kdy je šířka rámečku stále
stejná. Poklepáním na fixní ovladač přepneme rámeček na automatický formát, kdy se
přizpůsobuje napsanému textu.
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Každý blok textu se chová jako samostatný objekt, který nelze jinak upravovat než
textovým nástrojem. Použít text jako součást obrázku umožňuje funkce Break Apart viz
stejnojmennou kapitolu.

Panel Character a Paragraph — vzhled textu

Text upravujeme předem nebo dodatečně v panelech Character (znak) a Paragraph
(odstavec) (Window>Panels>Character/Paragraph). Pøedem mìníme atributy písma
po zobrazení textového rámeèku, dodateènì pak oznaèením celého bloku nástrojem
Select Tool (šipka), nebo pouze èásti pøímo pøi editaci oznaèením podobnì jako
v textovém editoru.

Nìkteré vzhledové vlastnosti písma mù�eme pøedem nastavit v hlavním menu Text.

Panely Character a Paragraph upravující vzhled psaného textu

Panel Text Options — významové vlastnosti textu

Panel Text Options (Window>Panels>Text Options) upravuje významové a funkční
vlastnosti textu. V prvním pop-up menu jsou na výběr tři typy: Static Text, Dynamic
Text a Input Text.
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Static Text
Nemá žádné specifické vlastnosti. V internetovém prohlížeči je ve finále zobrazován
jako normální needitovatelný text.

Use Device Fonts — pokud zatrhneme tuto vlastnost, předpokládáme, že návštěvník
stránky má na svém počítači nainstalován tentýž použitý font a proto ho není potřeba
zahrnout do výsledného souboru. To má vliv na zmenšení velikosti souboru a tedy
i na rychlejší načítání z internetu. Pokud ale host nemá tento font nainstalován, bude
text vypsán defaultním fontem, což může způsobit nečitelnost.

Selectable — text obsažený v animaci běžně není možné v prohlížeči označit
a případně zkopírovat. Tato funkce takovou možnost zajistí.

Input Text
Input Text je klasické textové pole, do kterého návštěvník stránky zadává potřebné
údaje např. atributy skriptů apod. Aby měl vstup nějaký smysl, přiřazujeme takovým
textovým polím proměnnou, do které načtenou hodnotu ukládáme a pak předáváme
skriptům nebo používáme v ActionScriptu. Nastavujeme i abecedu, jaká může být do
pole zadána, maximální počet znaků atd.

Panel Text Options nastavující významové vlastnosti textu

Dynamic Text
Tento typ textu umožňuje dynamické obnovování textu při častých změnách obsahu.
Můžeme nastavovat abecedu, kterou bude textové pole obsahovat, zda bude na jednu
nebo více řádek a proměnnou podobně jako Input Text. Dynamický text se dá dobře
využít při projektech, kde vkládáme vstupní hodnoty a počítač nám skrze tyto pole
odpovídá výstupní hodnotou např. pomocí externích skriptů.
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Organizace dokumetu

Vrstvy — násobení pracovní plochy

Celou animaci organizujeme do vrstev podobně jako v grafických editorech např.
Photoshop nebo Fireworks. Vrstvy jsou podobné průhledným fóliím, kde můžeme
na každou kreslit zvlášť a přesto všechny objekty vidíme. Pro animátora jsou vrstvy
nezbytnou pomůckou (stejně jako pauzovací papír při skutečné realizaci kresleného
filmu) a práci s nimi se rozhodně nevyhneme.

Každý dokument obsahuje minimálně jednu vrstvu, která se jmenuje Layer 1. Nyní
je potřeba se soustředit na panel vrstev umístěný vedle časové osy.

Panel vrstev spolu s časovými osami

Organizace zobrazení vrstev a k nim přidružených časových os je odůvodněná, protože
v každé vrstvě můžeme provádět různé změny v různém čase (rámečku) animace
nezávisle na ostatních.

V dokumentu si obvykle vytváříme několik vrstev, každou pro různé objekty (např.
tlačítkovou, animační, zvukovou...) a podle toho si také vrstvy pojmenováváme.
Vlastnosti jedné označené vrstvy můžeme měnit v samostatném dialogu, který se otevře
poklepání na ikonu nalevo od jména vrstvy.
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Vlastnosti vrstvy

Většinu vlastností vrstvy můžeme nastavit i přímo v panelu klikáním na jednotlivé
ikonky.

Existuje pět typů vrstev, které můžeme ve vlastnostech také dodatečně nastavit:
 Normální (Normal) — je běžná vrstva, která nemá žádné speciální postavení ani

funkci.
 Vodící (Guide) — vrstva obvykle sloučená s vrstvou vedenou. Obsahuje vodítka pro

animované objekty podle křivky (viz kapitolu Animace) a její
obsah není zobrazován ve výsledném klipu.

 Vedená (Guided) — vrstva obsahuje objekty, které jsou animovány podle křivky
v přidružené vrstvě vodící (viz kapitolu Animace).
Přetažením vrstvy normální na vrstvu vodící, proměníme tuto
vrstvu na vedenou.

 Maskovací (Mask) — obsahuje vyplňené objekty, které jsou průhledným výřezem
(maskou) pro vrstvu maskovanou. (viz Maskování).

 Maskovaná (Masked) — bývá sdružená s maskovací vrstvou (i s jinými
maskovanými vrstvami) a slouží jako zobrazovaný
podklad viditelný skrz výřezy v maskovací vrstvě. (viz
Maskování)

Lze měnit i pořadí vrstev, což je při animaci velmi důležité, neboť tím nastavujeme,
které vrstvy budou v popředí (v seznamu nejvýše) a které v pozadí (v seznamu nejníže).
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Přesouváme je pouhým tahem jmenovky. Vzájemně propojené vrstvy jako jsou vrstvy
masky a vodící, se přesouvají společně a jsou přehledně hierarchicky seřazeny.
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Množství vrstev je v dokumentu omezeno pouze pamětí počítače (tzn. až nepotřebně
mnoho), přesto ve výsledném dokumentu nezabírají žádné místo a je pouze na uživateli,
jaký počet vrstev pro návrh animace zvolí.

Maskování

Někdy potřebujeme dosáhnout efektu, kdy je např. skrz výřez viditelná pouze část
obrázku. K tomu slouží maskovací a maskované vrstvy.

1.  Vytvořme si nový dokument (File>New).
2.  První vrstvu přejmenujme na „Obrázek“ (poklepáním na jmenovku) a vložme do ní

libovolný bitmapový obrázek uložený na disku (File>Import).
3.  Přidejme vrstvu další (ikona plus v panelu vrstev). Tu nazveme „Kukátko“

a nakreslíme do ní (klikneme na jmenovku) malou kružnici přes obrázek ve vrstvě
první (výplň kružnice musíme ponechat).

4.  Ve vlastnostech vrstvy „Kukátko“ (poklepáním na ikonu vrstvy) nastavíme typ Mask
a pro vrstvu „Obrázek“ typ Masked.

5.  Výsledný efekt zobrazíme zamčením obou vrstev.

Kružnici z předchozího příkladu můžeme rozpohybovat jednoduchou animací (nikoli
však animací podle vodící vrstvy) a docílit tak přejíždění kukátka přes obrázek.
Působivým efektem je, když obrázek nakopírujeme ještě do jedné nejnižší vrstvy
a lehce ho upravíme nebo pozměníme.
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Maska, tedy objekt v maskovací vrstvě se může skládat z více vyplněných objektů
a jednou maskovací vrstvou může být maskováno více vrstev.

Symbol a jeho instance — stavební prvek animace

Symbol je libovolný objekt, který chápeme jako vzor nebo jakousi matrici pro objekty
z něho odvozené. Odvozeným prvkům říkáme instance a jsou přesnou kopií
rodičovského symbolu.

Symbol může být i skupina objektů nebo dokonce animace. Pokud tedy součástí
jediného klipu bude více totožných objektů, vytvoříme jeden vzorový symbol
a ušetříme tím značné místo ve výsledném souboru. Proto vždy platí jedna nadsazená
rada: „symboly vytvářejte vždy a všude“. I přesto, že objekt bude použit v dokumentu
pouze jednou.

Důležitou vlastností symbolů a jejich instancí je vzájemná propojenost. Editujeme-li
symbol měníme naprosto stejně i všechny instance z něho odvozené.



Macromedia Flash 5

41

Knihovna

Všechny symboly jsou ukládány do knihovny dokumentu (Window>Library), odkud je
mù�eme kdykoli nakopírovat na scénu a vytvoøit tak jejich instance. V knihovnì
mù�eme symboly organizovat stejnì jako v adresáøové struktuøe poèítaèe do slo�ek.
Mù�eme sem samozøejmì symboly i pøidávat a odstraòovat a abecednì øadit. Dùle�itá
je mo�nost pøejmenování symbolu poklepáním na jmenovku.

Panel knihovna s ulo�enými symboly

Speciálním pøípadem knihovny je tzv. sdílená knihovna (Shared Library). Slou�í jako
externí knihovna, která není pøímou souèástí dokumentu, který pøenášíme pøes
internet. To sni�uje velikost souboru a šetøí místo na disku, nebo� mù�eme vlastnit
na svém internetovém úètu napø. knihovnu zvukù a ka�dá námi vytvoøená animace si
potøebné objekty nahrává dodateènì. Doporuèeno je vytváøet sdílené knihovny co
nejmenší. Pokud toti� nastane chyba pøi pøenosu dat, animace nebude pøehrána.

Potøebnou sdílenou knihovnu mù�eme vytváøet jako normální dokument, kde
definujeme pouze symboly. Pro ka�dý symbol, který chceme poté exportovat, v menu
knihovny zvolíme polo�ku Linkage. V dialogu, který se zobrazí, zvolíme zda má být
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symbol exportován a pod jakým jménem (pokud si naopak pøejeme symbol importovat
do dokumentu, zvolíme jméno a adresu na které se nachází sdílená knihovna).

Dokument pak ulo�íme normálnì jako FLA soubor nebo exportujeme jako SWF
v pøípadì, �e chceme umístit knihovnu na internet.

Pøi exportu sdílené knihovny na internet je ještì nutné definovat adresu, na které
bude knihovna umístìna. Zvolíme v menu knihovny Shared Library Properties...
a adresu vlo�íme v podobì URL.

Symboly do dokumentu sdílíme tak, �e pøi jeho editaci otevøeme ulo�ený
dokument se sdílenou knihovnou volbou File>Open As Shared Library.... Objeví se
nový panel se sdílenou knihovnou odkud mù�eme pøetahovat symboly pøímo na
plochu nebo do knihovny dokumentu.

Knihovnu jiného dokumentu je mo�né otevøít prostì volbou File>Open As
Library...

Vytvoření symbolu

Symbol můžeme vytvořit úplně nový nebo můžeme použít existující objekt, který
na symbol přeměníme.
• Nový symbol editujeme volbou Insert>New Symbol...
• Na symbol přeměníme existující označený objekt volbou Insert>Convert To

Symbol...
• Duplikováním jiného v knihovnì oznaèeného symbolu volbou Duplicate v menu

knihovny
• Přetažením z jiné knihovny

V prvních dvou případech se otevře dialog, ve kterém musíme zvolit název pro
knihovnu a typ symbolu:

 Movie Clip — celá jednotná animace složená z více rámečků (okének). Vytváříme ji
stejně jako animaci doumentu.

 Button — tlačítko obsahující čtyři rámečky s různými stavy (Up, Over, Down, Hit).
Popis vytvoření naleznete v kapitole Interaktivní prvky animace.

 Graphic — obyčejný bitmapový nebo vektorový obrázek

Na typu symbolu závisí jeho další chování (Behavior) a vlastnosti a je možné ho změnit
i dodatečně klepnutím pravým tlačítkem na symbol v knihovně a zvolením typu
v položce Properties... nebo Behavior.

Speciální symboly:
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Font — textový font. Ten vytváříme v případě, že chceme vytvořit sdílenou
knihovnu a nevkládat tak zbytečně font do animovaného dokumetu (viz Knihovna).
Do knihovny ho vložíme otevřením menu v pravém horním rohu panelu a volbou
položky New Font....

Klip — symbol videoklipu importovaného ze souboru typu MOV (viz Import
souborů).

Sound — zvuk taktéž importovaný ze souboru (viz Zvuk).

Editace symbolu

Existující symbol editujeme několika způsoby:
• V knihovně označením symbolu a volbou Edit z menu nebo poklepáním na náhled

symbolu. Na pracovní ploše se zobrazí pouze tento objekt. Editaci ukončíme
kliknutím na záložku se jménem scény (přepneme se na ni).

 

 
 
• Na ploše poklepáním na instanci symbolu nebo volbou Edit in place z menu

(stisknout pravé tlačítko myši). Zbytek pracovní plochy se zamlží a mi editujeme
pouze symbol. Editaci ukončíme poklepáním mimo symbol nebo opět kliknutím
na záložku scény.

• V novém okně volbou Edit in New Window z menu pravého tlačítka myši. K editaci
symbolu se tak můžeme rychle opakovaně vracet, což je hodné při editaci složitých
symbolů.

Vytváření a upravování instance

Pokud jsme již vytvořili nějaký symbol, musí být přítomný v knihovně dokumentu
(Window>Library). Jeho instanci pak vytvoøíme tahem obrázku nebo jmenovky
symbolu na plochu, kam se nám nakopíruje. Další variantou je okopírování existující
instance bì�ným pøíkazem Edit>Copy/Paste, kopírováním celého rámečku animace
do jiného volbou Edit> Copy Frame/Paste Frame atd.

Každá instance pak vypadá jako symbol. Pokud se rozhodneme upravit symbol,
změní se všechny instance v animaci a dokonce upravujeme-li instanci přímo na ploše
(poklepáním), měníme zároveň rodičovský symbol v knihovně včetně všech ostatních
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instancí. Jedinou vyjímkou jsou vzhledové změny provedené transformací (zvětšování,
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zmenšování, rotace atd.) objektu nebo v panelu Effect (Window>Panels>Effect)
pùsobící pouze na konkrétní instanci.

Panel Effect definující efekt symbolu

druhy efektů:
• světlost (Brightnes) — světlost instance v rozmezí -100%(černý) — +100%(bílý).
• zabarvení (Tint) — procentuelní promítnutí nastavené barvy do barevnosti instance.
• průhlednost (Alfa) — procentuelní průhlednost objektu.
• kombinovaný (Advanced) — kombinace barevného prolnutí a průhlednosti.

Takových efektů lze velmi dobře využívat při vytváření zajímavých animací (viz
Animace).

Instanci mažeme stejně jako jakýkoli jiný objekt (např. označením a klávesou Del nebo
Edit>Cut) bez dalšího efektu (neberu v úvahu např. přerušení průběhu animace, pokud
vymažeme instanci v nevhodném rámečku). Smažeme-li symbol z knihovny, smažeme
tím pádem i veškeré jeho instance.

Break Apart — rozbití kontextu

Tato funkce v menu Modify>Break Apart je jakési rozbití objektu. Tuto funkci
mù�eme aplikovat na obrázky, instance symbolů a text a používáme ji v situacích, kdy
chceme zrušit jejich původní seskupení.

Obrázek, který importujeme na scénu ze souboru se chová jako needitovatelný
objekt. Pokud na něj aplikujeme tuto funkci budeme ho moci začlenit mezi ostatní
objekty, různě ho upravovat, rozebírat a používat jako výplň.

Takto lze pracovat i s textem, který tímto převedeme na editovatelné objekty
jednotlivých písmen. Instance symbolů vložené na scénu touto funkcí přeměníme zpět
na prostý objekt, který můžeme editovat bez vlivu na rodičovský symbol a opačně.
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Animace

Navrhujeme první animaci

Nejprve si otevřeme nový dokument a nastvíme jeho vlastnosti (Modify>Movie) (viz
kapitolu Nastavení dokumentu). Dùle�ité je správnì odhadnout rozmìry plátna, kvùli
zobrazení v prohlí�eèi. Pak mù�eme zaèít pracovat na novém klipu.

Animaci navrhujeme na plátnì a objekty organizujeme na èasové ose.

Časová osa dokumentu s několika druhy rámečků a animací

Èervený ukazatel symbolizuje místo, na které se v animaci právì díváme.
S jednotlivými rámeèky ka�dé vrstvy pracujeme podobnì jako s písmeny textu.

Mù�eme je tahem oznaèovat a pøesouvat. Je však velmi dùle�ité dodr�ovat urèitá
pravidla, nebo� bychom mohli vytrhnout nìkteré rámeèky z kontextu a animace by u�
potom nemusela pracovat správnì. Znalosti takových zásad získá ka�dý u�ivatel
ze zkušeností. Podstatou kvalitní tvorby je dodr�ování pøehlednosti.

Rámečky

Rámeček (okénko) je jednotkou animace. Každá vrstva má svou časovou osu
rozdělenou do rámečků. Klikneme-li do libovolného rámečku, můžeme do něj vložit
běžné nebo klíčové okénko animace (Insert>Frame/KeyFrame). Poté můžeme začít
kreslit.

Prvním vloženým rámečkem na časové ose bývá obvykle „keyframe“ (klíčový),
obsahující první objekt. Vložíme-li do libovolného následujícího rámečku „frame“
(běžný), objekt v předchozím klíčovém rámečku se nakopíruje automaticky do všech
rámečků mezi těmito dvěma. Klíčový rámeček vždy uvádí novou animovanou fázi
a pokud obsahuje nějaké objekty, je označen černým bodem. Pokud všechny obsažené
objekty vymažeme, rámeček zůstane klíčový, ale bude prázdný a oddělen od ostatních
svislou čarou. Čisté klíčové rámečky můžeme vložit volbou (Insert>Blank KeyFrame)
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bez toho, aniž by se obsah předchozích rámečků do tohoto okénka nakopíroval. To
používáme, pokud chceme začít animaci s novým objektem.

Do běžného rámečku nemůžeme kreslit individuální objekty, neboť vše co zde
nakreslíme nebo sem vložíme, se automaticky zkopíruje do všech ostatních rámečků
mezi rámečky klíčovými (včetně).

Klíèový rámeèek odstraníme volbou (Insert>Clear KeyFrame), èím� také
vyma�eme jeho obsah.

Obvykle klíèové rámeèky uzavírají èást animace, kde dochází k promìnì nebo pøesunu
jednoho objektu a mezi nimi jsou rámeèky bì�né:

Takto je zobrazena správnì ukonèená animace objektu (pohybová nebo efektová —
Motion Tween)

Toto zobrazení ukazuje správnì ukonèenou animaci zmìny tvaru objektu (Shape Tween)

Takto je zobrazena animace, kde nedochází k �ádné zmìnì objektu (KeyFrame
a na konci Frame)

Neukonèená animace objektu (není stanovena cílová pozice objektu — pouze navolena
animace Motion Tween)

Malé „a“ symbolizuje umístìní kódu ActionScriptu v tomto rámeèku

Rámeèek obsahuje poznámku nebo jmenovku (Label v panelu Frame)

K nastavení parametrù, podle kterých se bude rámeèek chovat, slou�í panel
Window>Panels>Frame, kde rámeček můžeme pojmenovat (pro odkaz v Action-
Scriptu) a nstavit charakter animace objektu obsaženého v něm (Motion — pohybová
animace, Shape — tvarová animace). Tyto varianty jsou popsány v kapitole Návody pro
animátory začátečníky.
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Scéna

V novém dokumentu klip obsahuje pouze jednu scénu, ale my mù�eme film rozdìlit
do více scén. Scény jsou vlastnì nezávislé animace sdílející stejnou knihovnu symbolù,
ale ve výsledném klipu jsou seøazeny za sebe a pokud není nastaveno jinak, pøehrávají
se nepøerušenì jedna za druhou a� do poslední.

K organizaci scén slou�í panel Window>Panels>Scene, kde jsou øazeny scény za
sebe. Mù�eme zde scény pøidávat i duplikovat a pøepínat se mezi nimi.

Návody pro animátory začátečníky

Motion Tween — pohybová a efektová animace

Nyní si na pøíkladu vysvìtíme, jak rozpohybovat objekt.

1.  Nejprve vytvoøíme symbol, který budeme animovat (Insert>New Symbol). Zvolíme
typ Graphic a vlo�íme název „Letadlo“. Nakreslíme letadlo a editaci ukončíme
kliknutím na jmenovku scény.

2.  První vrstvu dokumentu přejmenujeme poklepáním na jmenovku na „Let“ a
klikneme do prvního okénka této vrstvy.

3.  Otevřeme knihovnu dokumentu (Window>Library) a náš symbol přetáhneme na
plochu. Umístíme ho zcela vlevo.

4.  Klikneme do okénka 15 vrstvy Let a vlo�íme nový klíèový rámeèek
(Insert>Keyframe). Letadlo se automaticky nakopíruje do okének 2-15.

5.  V okénku 15 pøesuneme letadlo vpravo.
6.  Klikneme do libovolného okénka 1-14 a vytvoøíme animaci mezi klíèovými

rámeèky volbou Insert>Create Motion Tween. Mezi rámeèky 1-15 se objeví šipka,
jako indikátor správnì vytvoøené animace.

7.  Výslednou animaci si můžeme prohlédnout pomocí přehrávacích tlačítek
(Window>Toolbars>Controller) nebo volbou Control>Play.

Výsledná animace Motion Tween
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Animaci mù�eme dál nastavovat dalšími fázemi skrze klíèové rámeèky a další Motion
Tween.
Všimněme si, změny v rámečku č.1 v panelu Frame (Window>Panels>Frame) viz
následující obrázek.

Označený symbol s panelem Frame

Animaci můžem následovně upravit:
8.  Rozhodneme-li se letadlo postupně během letu zvětšovat/zmenšovat, klikneme

na poslední rámeček (15) animace a nástrojem Arrow Tool — Scale letadlo
zmenšíme/zvětšíme.

9.  V panelu Frame na prvním rámečku animace zaškrtneme políčko Scale pro
postupnou proměnu, jinak by se zvětšení/zmenšení neprojevovalo postupně, ale až
v posledním rámečku animace.

10.  Rotaci letadla (v našem leteckém případě spíše nelogickou) způsobíme otočením
letadla v posledním rámečku nástrojem Arrow Tool — Rotate.

11.  Vlastnosti rotace nastavíme opět v prvním rámečku animace v panelu Frame:
None — žádná
Auto — automatická
CW — po směru hodinových ručiček
CCW — v protisměru
TIMES — počet otočení pro CW a CCW

Dalšími speciálními úpravami animace jsou efekty, které uskutečňujeme v panelu
Window>Panels>Effect a to pouze na symboly a jejich instance.
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12.  V prvním rámeèku (klíèovém) animace klikneme na letadlo a zvolíme po�adovaný
efekt (viz Symboly — vytváøení a upravování instance).

13.  Jiný efekt nastavíme po kliknutí na letadlo v posledním rámeèku animace. Letadlo
se pøi pøehrávání zmìní plynulým pøechodem mezi efekty.

Efekt mù�eme nastavovat pouze v klíèových oknech animace.

Guide Motion — vedená animace

Pohybovou animaci, kterou jsme vytvoøili v pøedchozí kapitole mù�eme velmi snadno
rozvést a letadlo nechat pohybovat po urèité dráze, ani� bychom museli vytváøet
desítky klíèových rámeèkù a nastavovat animaci dalšími sekvencemi.

1.  Vytvoøme novou vrstvu (malé plus na panelu vrstev) a pojmenujme ji „Dráha letu“.
2.  Zmìòme vlastnost vrstvy (poklepáním na ikonu nalevo od jmenovky) na typ Guide.
3.  Vrstvu Let nastavme stejným zpùsobem na typ Guided. Vrstva bude mírnì odsazena

a tedy podøízena vrstvì Dráha letu.
4.   Pøepnìme se na první okénko vrstvy Dráha letu a nakresleme tu�kou dráhu letu

napø. s protoèením (viz následnující obrázek). Symbol letadla automaticky
„pøiskoèí“ na zaèátek této vodící èáry. Pokud se tak nestane (napø. pokud jsme
nezachovali správný postup nebo jsme typ vrstev navolili a� po nakreslení vodící
èáry, vrstvy logicky slouèíme volbou Insert>Motion Guide ve vrstvě Let.

5.  Pokud se tak automaticky nestalo, vlo�íme do vrstvy Dráha letu do okénka 15
bì�ný rámeèek (Insert>Frame), i kdy� to není bezpodmíneènì nutné.

6.  Pøepnìme se nyní na poslední okénko vrstvy Let a nastavme pøichytávání objektù
(View>Snap To Objects). Tahem pak přeneseme letadlo na konec vodící linky
a pomocí malého kolečka, které se po přiblížení zobrazí, přichytíme.

7.  Nyní mù�eme animaci pøehrát tlaèítky Controller. Letadlo se pohybuje po námi
nakreslené vodící lince, ale neotáèí se ve smìru pohybu, zùstává stále ve vodorovné
poloze a zdaleka nepøipomíná reálný let. Proto udìláme menší úpravu.

8.  Otevøeme panel Window>Panels>Frame a přepneme do prvního okénka vrstvy Let.
V panelu pak zaškrtneme políčko Orient To Path, čímž efektu docílíme.
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Výsledná animace Guide Motion

Shape Tween — tvarová animace

Tvarovou animaci mù�eme aplikovat v animacích tzv. morfingu, tedy tvarové pøemìny
objektu. Rozdíl od Motion Tween a tedy i Guided Tween je, �e tvarovou animaci
nemù�eme aplikovat na symboly a jejich instance.

Na pøíkladu pøemìny ètverce v kru�nici uká�i, jak takovou animaci vytvoøit.

1.  Do prvního rámeèku libovolné vrstvy nakreslíme na levou stranu plochy modrý
ètverec nebo obdélník.

2.  Klikneme na rámeèek 10 a vlo�íme klíèový rámeèek (Insert>KeyFrame).
3.  V tom samém rámečku buď čtverec, který se sem nakopíroval, upravíme, nebo ho

úplně smažeme a nakreslíme červený kruh na pravou stranu plochy.
4.  Otevřeme panel Frame, klikneme do prvního rámečku vrstvy a zvolíme typ Shape v

pop-up menu Tweening.
5.  Nakonec nastavíme Easing (zrychlování/zpomalování) a Blend (způsob

rozanimování objektu) — Distributive více rozostřuje a zaobluje tvary, Angular
zachovává ostrost rohů a hran.

6.  Animace je hotová a my si ji můžeme přehrát.
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Výsledná animace Shape Tween

Přestože je možné do jedné vrstvy vložit více jak jeden měněný objekt (např. můžeme
rozdělit jeden objekt ve více jak jeden nebo naopak), raději k tvarovým přeměnám
různých objektů používáme různé vrstvy.

Frame-by-frame — klasická animace „obrázek po obrázku“

Klasickou animaci je možné ve Flashi vytvořit velmi jednoduše, ale o to více náročná
bude kresba jednotlivých obrázků. Proto si nejprve musíme nakreslit nebo importovat
několik obrázků, které budou základem animace. Ukáži jak nakreslit animaci
vzpírajícího člověka, kterou bude možno neustále dokola opakovat.

1.  Nakreslíme si čtyři fáze člověka (viz obrázek) a převedeme je na symboly typu
Graphic se jmény 1,2,3,4. Všechny instance z plochy odstraníme.

2.  Vytvoříme si na časové ose 6 prázdných klíčových rámečků za sebou (můžeme
použít klávesu F6).

3.  Postupně do každého vkládáme po jedné instanci symbolu 1,2,3,4,3,2, čímž zajistíme
plynulé opakování animace.

4.  Pro správné umístění obrázků nyní použijeme funkci Onion Skin, kterou ovládáme
tlačítky pod časovou osou.
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Nastavení funkce Onion Skin — průhlednost rámečků

Onion skin nám zprůhledňuje okénka a umožňuje editaci více rámečků najednou.
5.  V jednotlivých rámečkách můžeme nyní srovnat fáze správně na sebe.
6.  Animace je hotová a my si ji můžeme přehrát. Opakování animace

zapneme/vypneme volbou Control>Loop Playback.

Interaktivní prvky animace

Hlavním interaktivním prvkem dokumentu jsou tlačítka. Jak už bylo řečeno v kapitole
Symbol a jeho instance, pro tlačítka je vyhrazen speciální typ Button. Je to v podstatě
jediný objekt ve Flashi citlivý na pohyb a klikání myši.

Tlačítko je tedy vždy symbol a jeho vytvoření si nyní ukážeme.

1.  Vytvoříme nový symbol typu Button se jménem „Tlačítko“ (Insert>New Symbol).
Na èasové ose se objeví ètyøi rámeèky symbolizující fáze promìny tlaèítka:
Up — tlaèítko v klidovém stavu
Over — pøi ukázání myší
Down — stisknuto
Hit — tato fáze není v animovaných klipech zobrazována, proto nemusí být kreslena.
Slou�í jako definování prostoru, ve kterém je tlaèítko citlivé na dotek nebo stisknutí,
pokud není fáze Hit definována, nahrazuje se fází Up. Samozøejmì, �e mù�e být
vìtší nebo menší ne� viditelná èást tlaèítka.

2.  Pøed kreslením jednotlivých fází (kromì první), musíme vlo�it do jednotlivých
okének klíèový rámeèek (Insert>Keyframe).

3.  Pro správnou funkci tlaèítka je vhodné nakreslit alespoò první fázi tlaèítka. Pro
efektní funkci je vhodné kreslit vèechny. Dùle�ité je správnì tlaèítka správnì
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vycentrovat nad
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sebe, aby pøi aplikaci v klipu takzvanì „neposkakovala“. K tomu slou�í opìt funkce
Onion Skin nebo pokud jsou všechny fáze tlaèítka stejné a liší se pouze v barevnosti,
u�íváme editaèní funkci Copy/Past In Place, která kopíruje zvolený objekt na stejné
místo.

Rozdìlení fáze tlaèítka do jednotlivých rámeèkù symbolu Button

4.  Tlačítko je hotové a můžeme tedy jeho instanci vložit na scénu. Jeho funkci můžeme
kontrolovat rovnou v editoru volbou Control>Enable Simple Buttons.

Do ka�dé fáze tlaèítka mù�eme vkládat nejen kresby nebo grafické symboly, ale
i symboly animované (Movie Clip).

Pøidìlování akce tlaèítku bude vysvìtleno v následující kapitole.

Action Script — funkční popis interaktivity

ActionScript je jazyk, ve kterém jsou popisovány funkce jednotlivých objektù animace.
Ve verzi 5 je tento jazyk velmi rozsáhlý a umo�òuje vytváøet plnohodnotné stránky
vèetnì tlaèítek, formuláøù, øízených animací apod.

ActionScript je podobný jiným skriptovacím jazykùm (JavaScript) a všeobecnì
známým procedurálním jazykùm jako je C nebo Java, nebo� také obsahuje funkce,
operátory, promìnné atd. Není proto tì�ké se s tímto jednoduchým jazykem nauèit
pracovat.

Kód editujeme skrze editor Actions (Window>Actions), kde můžeme editovat buď
objekty (symboly typu buttons nebo movie clip), nebo rámečky animace.

Tlačítkům generujeme kód z důvodu interaktivity, animaci pak např. kvůli akci,
kterou chceme provést když přehrávaná sekvence dosáhne určitého rámečku.



Macromedia Flash 5

56

Panel Object Action pro psaní a vkládání Action Scriptu

Klíèová slova ActionScriptu jsou pro pøehlednost a logickou spojitost øazeny do sekcí:
Basic Actions — základní akce
Actions — vyšší akce
Operators — operátory
Functions — funkce
Properties — definovatelné vlastnosti cílových objektù
Objects — seznam objektù, které mají své vlastní funkce

Přidělení akce klíčovému oknu

Kód akce je mo�né vkládat pøímo do klíèového okna na èasové ose, které bude
oznaèeno malým „a“. Tzn. �e akce bude provedena dosáhne-li probíhající animace
konkrétního rámeèku s nadefinovanou akcí.

Kód vkládáme otevøením editoru Actions (Window>Actions) a kliknutím
na požadované okénko animace.

Základními akcemi (Basic Actions) užívanými v kódu rámečku jsou:
Goto — přeskakuje na konkrétní okénko animace
Stop — zastavuje přehrávání animace
Play — spouští přehrávání
Toggle High Quality — nastavuje vysokou kvalitu zobrazení
Stop All Sounds — zastavuje přehrávání zvuků



Macromedia Flash 5

57

Get URL — odkaz na cílovou stránku internetu
FSCommand — základní informace pro přehrávač FlashPlayer, pro zvětšení obrazovky
atd.
Load Movie — nahrává jiný externí SWF dokument a přehrává ho současně s právě
spuštěným
Unload Movie — odstraňuje nahraný SWF dokument
Tell Target — oslovuje cíl — pojmenovanou instanci (viz Symbol a jeho instance) a
přiřazuje jí akci
ifFrame Is Loaded — akce používaná pro získávání informací o stavu nahrávaného
dokumentu z internetu pro vytváření „preloaderů“ (krátká animace pro zabavení
návštěvníka před načtením hlavního dokumentu).

Přidělení akce tlačítku

Ka�dé tlaèítko musí mít nadefinovaný svùj kód, aby vùbec interaktivnì fungovalo (bylo
citlivé na stisk, dotek apod. Pro náš příklad použijme libovolný symbol Button.
Vytvoříme akci, kdy po stisknutí tlačítka animace přeskočí z rámečku 1 na rámeček 10
a zpět.

1.  Vložme BlankFrames do rámečku 1 a 10 v první vrstvě dokumentu.
2.  Do rámečků 1 a 10 vložíme symbol tlačítka z knihovny a text podle obrázku.
 

 
3.  Otevřeme editor Actions (Window>Actions) a klikněme na tlačítko v prvním

rámečku.
4.  Ikonou (+) vybíráme akci, funkci, operátor atd., který bude vložen do kódu. V tomto

případě přidejme ze sekce Basic Actions akci On Mouse Event („na událost myši
proveď“). Událost (Event) zadejme pouze pro stisknutí (Press) a poté zvolíme další
akci z Basic Actions — Goto („jdi na“). Číslo cílového rámečku zadáme 10 (Frame
Number) a zrušíme volbu Goto and Play, která způsobuje spuštění animace.

on (press) {
gotoAndStop (10);

}
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5.  To samé provedeme pro tlačítko v 10-tém rámečku, pouze nastavení Frame Number
bude 1.

on (press) {
gotoAndStop (1);

}

6.  Ještě musíme nastavit zastavení animace v prvním a desátém okně animace, aby se
nám po spuštění okamžitě nepřehrál celý obsah dokumentu. To zajistíme kliknutím
do prvního rámečku a volbou akce Basic Action — Stop. To samé naeditujeme
do rámečku č. 10.

Výsledek si můžeme prohlédnout klikáním na tlačítka po nastavení volby
Control>Enable Simple Buttons.
Podobně můžeme editovat další vlastnosti tlačítka reagující na (akce On Mouse Event):
Press — stisknutí tlačítka
Release — uvolnění
Release Outside — uvolnění mimo tlačítko
Keypress — stisk klávesy
Roll Over — přesunutí kurzoru nad tlačítko
Roll Out — přesunutí mimo tlačítko
Drag Over — kliknutím mimo tlačítko a táhnutí nad něj
Drag Out — kliknutím na tlačítko a táhnutím mimo něj

Importování souborů do dokumetnu

Do vlastního dokumentu můžeme importovat velkou škálu typů od hudebních (MP3,
WAV) přes grafické (GIF, JPEG, BMP...) až po filmové klipy (MOV). Objekty tedy
imporutjeme přes dialog (File>Import...), kde pouze vybíráme požadovaný soubor.
Každý takto vložený objekt je automaticky zařazen do knihovny dokumentu.

Bitmapové obrázky — vložením obrázku samozřejmě narůstá velikost výsledného
souboru. Proto je základní možností u každého bitmapového symbolu v knihovně
editací nastavit kompresy každého obrázku zvlášť. Poklepáním na náhled v knihovně se
otevře dialogové okno, ve kterém nastavujeme optické uhlazení (Allow Smoothing),
druh komprese (Compression) a případně i kvalitu (Qualitty). Nastavení těchto
vlastností umožní zmenšit výsledný soubor na požadovanou velikost. Samotné obrázky
můžeme editovat v externím grafickém editoru nebo použít metodu převedení bitmapy
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do vektorové grafiky (Modify>Trace Bitmap). Mo�né je i pou�ití funkce Break Apart
popsané ve stejnojmenné kapitole.

Vektorové obrázky — je možné vkládat do dokumentu stejně jako bitmapové, ale
Flash 5 podporuje pouze některé vektorové formáty. Pro kombinované typy jako je
formát užívaný Macromedia Fireworks (PNG) je vždy otevřeno dialogové okno,
ve kterém zadáváme zda má být obrázek importován jako bitmapa (Flatten Image) nebo
má být rozdělen do knihovny po jednotlivých objektech (Import Editable Objects).

Videoklipy — Macromedia Flash 5 umožňuje importovat pouze soubory typu MOV.
Ty můžeme při editaci v knihovně pouze pojmenovávat, případně zadávat adresářovou
cestu k jejich umístění. Při vkládání do samotného klipu vkládáme film do klíčového
rámečku a za ním vkládáme rámečky podle délky vloženého filmu, neboť je přehráván
pouze do té doby, dokud běží přehrávání našeho dokumentu.

Zvuk — vkládání a kompresy zvuku vysvětlím v kapitole Zvuk.

Export dokumentu

Macromedia Flash 5 nám umožňuje exportovat dokument jako samostatný
neinteraktivní videoklip různých formátů (SWF, AVI, MOV, GIF atd.) Stačí pouze
zvolit menu File>Export Movie....

Právě viditelnou část klipu exportujeme volbou File>Export Image jako bitmapový
obrázek zvoleného typu.

Zvuk

V Macromedia Flash 5 můžeme pracovat se zvukovými soubory typu WAV a MP3
(soubory AIFF jsou určeny pouze pro počítače Macintosh).

Zvukové soubory importujeme do dokumentu stejně jako jakékoliv jiné soubory
(File>Import). Ty se okamžitě vloží  do knihovny a my je můžeme ihned použít.

Vkládání zvuku do animace

Zvuk vkládáme vždy do konkrétního rámečku a to buď přímo přetažením symbolu
zvuku z knihovny na plochu v požadovaném rámečku, nebo přehledněji pomocí panelu
Sound (Window>Panels>Sound).
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Panel Sound pro vkládání zvuku do animace

V pop-up menu Sound jsou k dispozici všechny zvuky knihovny. Můžeme zvolit
libovolný, ale pouze jeden pro daný rámeček. Pokud chceme zvolit více zvuků a
spouštět je v jednom čase, musíme je vkládat do různých vrstev. Vložený zvuk se
projeví na časové ose zobrazením zvukové stopy.

V klíčovém rámečku, do kterého byl zvuk vložen, můžeme nastavit jeho vlastnosti
a efekty. Pop-up menu Effekt nabízí několik zvukových efektů:

Left/Right Channel — přehrává zvuk pouze v levém/pravém reproduktoru (kanálu)
Fade Left To Right — plynule přechází z levého do pravého
Fade Right To Left — plynule přechází z pravého do levého
Fade In/Out — zvuk postupně zesiluje/zeslabuje
Custom — nastavení vlastního zvukového efektu. Po této volbě nebo po stisku tlačítka
Edit..., se otevře okno, ve kterém pomocí ukazatelů nastavujeme zeslabení/zesílení
v obou kanálech zvlášť. Ukazatele přidáváme kliknutím a odebíráme odtažením mimo
panel.
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Dialog Edit Envelope (Custom...) pro editaci vlastního zvukového efektu

Pop-up menu Sync neboli synchronizace nabízí k výběru čtyři atributy zvuku:

Event — zvuk nezávislý na časové ose. Je přehráván, i když je animace ukončena
a skončí své přehrávání až když je na konci své stopy. Typickým využitím tohoto typu
synchronizace jsou zvuky v tlačítkách, kde je po stisknutí nebo ukázání na tlačítko
přehrán zvuk. V tom případě vkládáme zvuk do jednotlivých fází Up, Over a Down.
Start — stejné vlastnosti jako zvuk Event, pouze pokud je již tento zvuk přehráván,
začne se přehrávat nová instance zvukového symbolu.
Stop — zastaví přehrávání zvuku. Např. umístíme-li do 1. a 5. rámečku stejný zvuk
(nejlépe delší než je doba přehrávání pěti okének animace), a v pátém rámečku
nastavíme synchronizaci Stop, bude přehrávání zvuku spušťeného v rámečku 1
přerušeno.
Stream — zvuk závislý na časové ose. Přehráván je pouze pokud běží animace, jakmile
zastaví, je zastaveno i přehrávání zvuku.

Každému zvuku můžeme v klíčovém rámečku určit také počet opakování (Loop).
Při kontrolním přehrávání zvuků je důležité nezapomenout vypnutou fci

Control>Mute Sounds, kterou tlumíme všechny zvuky animace.
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Nastavení komprese zvuku pro export dokumentu

Pro každý zvuk v knihovně můžeme nastavit druh komprese, podle které bude
exportován do výsledného souboru, což nám dovolí smrsknout velikost souboru
na minimum. Musíme však brát v úvahu, že kvalita zvuku je přímo úměrná velikosti
výsledného souboru.

Pokud začneme editovat zvuk jako jakýkoli jiný symbol (např. poklepáním na
obrázek v knihovně), zobrazí se dialogové okno informující nás o původu a atributech
zvukového souboru. Právě v tomto okně nastavujeme druh kompres v pop-up menu
Compression:

Default — je nastavení, které je provedené v publikačních vlastnostech celého
dokumentu (viz Publikování dokumentu)
ADPCM — je komprese užívaná pro krátké nepodstatné zvuky např. klikání tlačítek.

Preprocessing — převádí zvuk ze sterea na mono (jeden kanál), čímž je
ještě více komprimován.

Sample Rate — je vzorkovací frekvence zvuku (přímo úměrná velikosti
souboru a kvalitě).

ADPCM Bits — bitová hloubka zvuku.
Pod těmito volbami se okamžitě zobrazuje výsledná velikost souboru.

MP3 — je známá komprese určená pro export delších zvukových nahrávek hudby.
Preprocessing — převod stereo na mono
Bit Rate — bitová rychlost v kilobytech za vteřinu.
Quality — kvalita výsledného zvuku.

Raw — exportuje zvuk bez komprese. Můžeme pouze nastavit převod na mono zvuk
a vzorkovací frekvenci, čímž snížíme velikost.

Publikování dokumentu

Pro úspěšné dokončení práce na vytvářeném dokumentu je nutné provést tzv. publikaci,
tedy uložení definitivní podoby dokumentu pro umístění na web případně na cd-rom,
disk atd. Před tím, než tento krok provedeme, si můžeme (a je to i vhodné) výsledek
prohlédnout a otestovat jeho funkčnost.

Testování vytvořeného dokumentu

Klip můžeme testovat buď přímo v prostředí Macromedia Flash 5 (Control>Test
Movie). V takovém pøípadì se otevøe nové okno, ve kterém se promítá výsledný



Macromedia Flash 5

63

dokument se všemi mo�nostmi interaktivity vèetnì citlivosti tlaèítek. Zároveò se otvírá
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malé informativní okénko (Window>Output) informující nás o aktuálních výstupech
a případných chybách v kódu ActionScriptu. Pro pokročilejší a detailnější náhled
s možností odstraňování chyb volíme Control>Debug Movie s panelem Debugger
(Window>Debugger). Zde máme možnost nahlížet a upravovat stav proměnných
(Varriables) a vlastností (Properties) včetně vkládání vlastních výrazů (Watch) pro
kontrolu ActionScriptu.

Funkčnost právě aktivní scény testujeme volbou Control>Test Scene.
Přímo při editaci můžeme procházet a přehrávat animace přes ovládací panel

Window>Toolbars>Controller, přičemž opakované přehrávání zapínáme menu
Control>Loop Playback a přehrávání všech scén za sebou Control>Play All Scenes.

Vlastnosti publikování

Každý dokument můžeme publikovat s různými atributy a s různými požadavky na
velikost a formu. Dialog těchto nastavení vyvoláme File>Publish Settings....

Ve složce Formats nastavujeme, do jakého formátu chceme dokument publikovat
(uložit, převést). Implicitně jsou zaškrtnuty formáty Flash a HTML.
• Flash — generuje soubor typu SWF, tedy typický formát pro přehrávání pomocí

FlashPlayeru na i mimo internet. Zachovává interaktivitu.
• HTML — generuje HTML kód důležitý pro spuštění dokumentu na internetu

a umístění na www stránky. Je vhodné ho nechat vytvářet a pak ho vkládat do vlastní
stránky.

• GIF — ukládá dokument do grafického statického nebo animovaného formátu GIF.
• JPEG, PNG — ukládá dokument jako grafický bitmapový obrázek těchto typů,

zobrazující se jako alternativa při absenci FlashPlayeru.
• Windows/Macintosh projector — alternativní samostatné soubory umožňující

promítání dokumentu na jednotlivých platformách bez nutnosti vlastnit FlashPlayer
(EXE, HQX).

• QuickTime — generuje film ve formátu MOV.
• RealPlayer — generuje soubor SMIL pro známý on-line přehrávač.
Přednastavené názvy jednotlivých souborů můžeme měnit po odškrtnutí políčka Use
Default Names.

Po zaškrtnutí libovolného formátu se zobrazí záložka, ve které je možné nastavit
vlastnosti, na nichž závisí kvalita a velikost výsledného dokumentu.

Nejpodstatnější je nastavení záložky Flash, neboť v tomto formátu budete
dokumenty publikovat nejčastěji.
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Záložka Flash dialogu Publish Preview pro nastavení publikování ve formátu SWF

O správném resp. nesprávném nastavení publikování se můžeme přesvědčit náhledem
File>Publish Preview.

Samotné publikování spustíme buď přímo z Publish Settings tlačítkem Publish nebo
volbou v menu File>Publish. Soubory jsou ukládány tam, kde je uložen zdrojový
soubor FLA (File>Save).
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Macromedia Fireworks 3

Program Macromedia Fireworks 3 je grafickým nástrojem, určeným pro vytváření
vizuálních prvků internetových stránek. Mohlo by se zdát, že se jedná o další naprosto
průměrný přírůstek do rodiny grafických editorů. Skutečnost je však jiná, neboť právě
Fireworks nám představují nový pohled na tvorbu statické, tak i částečně animované
grafiky, na její prezentaci a komplexní využití právě v prostředí internetu. Nabízejí
mnoho nových nástrojů a technik a to je staví mezi nejlepší editory.

Spíše než editor bychom měli Fireworks nazvat krkolomně „kompozitor“ nebo
„skladatel“. Hlavně proto, že jejich funkcí je kombinování vektorové a bitmapové
grafiky. Fireworks totiž pracují v prostředí vektorové, ale i bitmapové grafiky,
kde dotváříme fotografie a následně komponujeme do logického celku pomocí vektorů.
Fireworks jsou tedy určeny hlavně pro vytváření bitmapového obrazu s využitím
vektorové grafiky. To představuje dokonalou přehlednost a jednoduchost editace,
možnosti odebíraní či přidávání kreseb do obrazu, s čímž souvisí i perfektní variabilita
již vytvořených čar, úseček, kružnic atd., s jakou se setkáváme ve vektorově
orientovaných editorech, např. CorelDraw.

Hlavní zbraní Fireworks je možnost vytvářet animované či statické obrázky, ty pak
doslova „rozřezat“ a vytvořit tak například efektně kompaktní grafiku plnou
nenápadných odkazů, aniž bychom poznali kde jsou skutečné okraje pomyslného
tlačítka (rollovers — tlačítka citlivá na přítomnost kurzoru myši, slices, image maps —
takzvané „klikmapy“). To právě za pomoci Fireworks zvládnete velmi jednoduše i Vy
bez složitého rozdělování obrázku na menší soubory a bez sestavování kódu v HTML
jazyce a následně i obrazu přímo na stránce, kde jednotlivé dílky „tak nějak“ nesedí
při sobě. Fireworks totiž obsahují velmi důmyslný systém exportu do několika souborů
spolu s HTML a JavaScript kódem potřebným pro základní funkčnost. Tak je tedy
možné vytvořit sice jednoduchou grafickou leč fungující stránku s odkazy, nebo
importovat Váš výtvor do Macromedia Dreamweaveru či jiného HTML editoru
a zakomponovat do připravované stránky spolu s textem, tabulkami, animacemi atd.

V následujících kapitolách Vám vysvětlím základní funkce Fireworks. Budu se
soustředit na vytváření těchto grafických webovských kompozic a jejich export a
případné následné užití, neboť se domnívám, že tuto jedinečnou schopnost Fireworks
budete využívat nejčastěji.
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Vzhled Fireworks

Program Fireworks vypadá na první pohled jako klasický grafický editor vyšší úrovně.
Pod hlavní lištou je typické menu, které se po otevření souboru rozšíří na devět položek.
Jen vyjímečně budu popisovat přímo jednotlivé volby menu. Spíše na ně budu
odkazovat pomocí  cesty jak k nim dospět (např.: (Window>Toolbar>...)) v souvislosti
s dalšími prvky pracovní plochy, protože se na volby menu lze odvolat rychleji i
pomocí ikon nebo panelů, o kterých bude řeč později.
Dalšími viditelnými částmi jsou dvě řady ikon urychlující přístup k vybraným funkcím,
panel nástrojů a pracovní plocha, na které se otvírají okna editovaných souborů
a případně i okénka panelů. Samozřejmostí je i dolní stavová lišta.

Vzhled Macromedia Fireworks 3

Pracovní plocha

Na tento prostor soustředíme celou naší pozornost. Jak už bylo řečeno je sem možné
otevírat okna souborů a pomocných inspektorů. Je sem však možno přesouvat i lišty
s ikonami a nástroji. To je velmi důležité při práci samotné, neboť nám umožňuje
osobní uspořádání „pracovního stolu“, což ocení hlavně uživatelé s malým monitorem.
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Panel nástrojů — Toolbox

Nepřehlédnutelnými ikonami na pracovní ploše jsou Pracovní nástroje a přestože je lze
vypnout (Window>Toolbox), budou pravděpodobně neustále přítomné díky své
důležitosti.

Panel nástrojů s částí pro nastavení barev

Ikony s černou šipečkou v pravém dolním rohu se dají měnit tak, že podržíme stisknuté
tlačítko myši nad danou ikonou a ze zobrazeného seznamu vybereme. tu, se kterou
chceme pracovat.

Součástí panelu Toolbox jsou i tlačítka pro volbu barvy výplní a hran objektů.
Musím upozornit, že při editaci vektorové a bitmapové grafiky mění některé nástroje

svou ikonu a funkci automaticky a některé v bitmapové grafice vůbec nefungují kvůli
své specializaci.

Při poklepání na ikonu libovolného nástroje se vždy otevře malý panel
(Window>Tool Options), tedy pomocník poskytující informace a atributy zvoleného
nástroje.
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Panel Options s nastavením zvoleného nástroje

Toolbars — nástrojové ikony

Vedle panelu nástrojů jsou na pracovní ploše ještě dvě lišty plné ikon usnadňujících
volání vybraných funkcí. Všechny je možné libovolně přesouvat. Hlavní (Window>
Toolbars>Main) je umístěna těsně pod hlavním menu a obsahuje všechny základní
funkce.

Druhá skupina takzvaně modifikačních ikon (Window>Toolbars>Modify) je obvykle
umístěna těsně nad nejnižší stavovou lištou (View>Status Bar), která kromě informací
o nástroji a označených objektech obsahuje také v pravé části tlačítka pro pohyb
po jednotlivých okénkách vytvářené animace.

Modifikační funkce mají opodstatněný název. Umožňují totiž modifikaci jednotlivých
objektů i celých skupin pouhým stisknutím ikony a jsou sdruženy v hlavním menu pod
položku Modify.
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Název Položka menu Funkce
Group Modify>Group Seskupuje objekty v jeden

„logicky“
Ungroup Modify>Ungroup Rozděluje dříve seskupené

objekty
Join Modify>Join Spojuje objekty v jeden

„fyzicky“
Split Modify>Split Rozděluje spojené objekty

Bring To Front Modify>Arrange>Bring To
Front

Přenáší objekt do popředí
(vizuálně)

Bring To Forward Modify>Arrange>Bring To
Forward

Přenáší objekt o jeden stupeň
výše

Send To Backward Modify>Arrange>Send To
Backward

Přenáší objekt o jeden stupeň
níže

Send To Back Modify>Arrange>Send To
Back

Přenáší objekt na pozadí

Align Modify>Align>... Umisťuje vybrané objekty
podle schématu vybraného
v pop-up menu

Rotate 90° CCW Modify>Transform>Rotate
90° CCW

Otáčí objekt o 90°C proti
směru hodinových ručiček

Rotate 90° CW Modify>Transform>Rotate
90° CW

Otáčí objekt o 90°C po směru
hodinových ručiček

Flip Horizontal Modify>Transform>Flip
Horizontal

Převrací objekt horizontálně

Flip Vertical Modify>Transform>Flip
Vertical

Převrací objekt vertikálně

Nalevo od ikon Modify jsou opět přesuvné ukazatele zobrazení (Window>Toolbars>
View Controls) informující nás o aktuálním procentuelním zvětšení obrazu (Fireworks
umožňují zmenšení až na 6% původní velikosti a až 64 000% zvětšení) a o aktuálním
nastavení zobrazovacího modu. Ten je možné měnit pomocí „pop-up“ menu:
• Full Display (View>Full Display) — zobrazuje kompletní a finální vzezření našeho

obrazu včetně výplní a textur.
• Draft Display — zobrazuje pouze „cesty“ (úsečky) a „kostry“ jednotlivých objektů

kvůli přehlednosti a rychlosti překreslování obrazu. Je určen pouze pro návrh obrazu.
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Obě tyto položky jsou aktivní až po otevření či vytvoření dokumentu, zároveň s nimi
se uvolní i tlačítko Page Preview sloužící k rychlému zobrazení základních informací
aktuálního okna.

Pravítka, mřížky a vodítka

Součástí pracovní plochy nebo spíše plátna mohou být i tzv. pravítka (Rulers), na která
se promítá aktuální poloha kurzoru a umožňují nám orientaci ve vzdálenostech na
plátně (View>Rulers). Jednotky pravítka jsou uváděny v pixelech, tedy grafických
bodech (picture element — nejmenší prvek obrazu). Každý otevřený soubor má
pravítka umístěna tak, že počátek pravítka vertikálního, tak i horizontálního je nastaven
na levý horní okraj obrazu. To se však dá při potřebě jednoduše změnit tím, že myší
uchopíme bod, ve kterém se pravítka sbíhají a přesuneme na místo v obrázku, kam
chceme počátek přesunout. Vrátit původní nastavení lze poklepáním opět na sbíhající se
pravítka.

Velmi užitečnou pomůckou je také mřížka nebo síť (View>Grid). Po její aktivaci
se na plátně zobrazí svislé a vodorovné přímky, stejné jako na milimetrovém papíře.
Umožňují nám snadnou orientaci ve vzdálenostech a rozmístění jednotlivých objektů,
ale ještě navíc, pokud je tato funkce aktivní (View>Grid Options>Snap to grid), nám
dovolují „přichytávat“ objekty na přesně určenou polohu v mřížce. Další vlastnosti,
jakými jsou barva a rozestup přímek je možné nastavit v dialogu View>Grid
Options>Edit Grid....

Vodítka neboli Guides (View>Guides) jsou pomocné linky, které vytvoříme stisknutím
tlačítka myši na vodorovném respektive svislém pravítku a tažením na plátno. Slouží
stejně jako mřížka pouze k návrhu obrázku. Mají také stejnou vlastnost přichytávání
objektů (View>Guide Options>Snap To Guides), mohou být přesuvné, ale tuto
vlastnost lze také potlačit (View>Guides Options>Lock Guides). Barvu a další možnosti
jsou měnitelné také přímo v nastavení průvodců v menu View>Guides Options>Edit
Guides.

Otevření dokumentu

Je několik způsobů jak začít editovat soubor:
• Založením nového souboru (File>New) — otevře dialogové okno, ve kterém

nastavíme vlastnosti nového dokumentu včetně šířky, výšky, rozlišení (hustota bodů
na čtvereční palec/centimetr) a barvy/průhlednosti plátna.
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• Otevřením existujícího souboru (File>Open...) — otevře se dialogové okno kde
vybereme požadovaný soubor všech možných grafických typů.
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• Otevřením více souborů najednou (File>Open Multiple...) — zde můžeme vybrat
více souborů najednou např. za účelem vytvoření animace

• Naskenováním předlohy (File>Scan) — pro tyto účely je nutné vlastnit
hardwarové a softwarové vybavení scanneru. Scan Acquire automaticky spouští
scanner nastavený jako hlavní, Scan Select nabízí zařízení k výběru.

• Přetažením souboru metodou Drag&Drop — uchopíme soubor např.
v průzkumníkovi a přetáhneme na pracovní plochu Fireworks.

Vlastnosti otevřeného dokumentu můžeme dále modifikovat v menu Modify:
Image Size — zde měníme velikost obrázku
Canvas Size — mění rozměry plátna
Canvas Color — nastavuje barvu/průhlednost plátna

Uložení dokumentu

Fireworks dovolují ukádat dokument ve formátu PNG, který obsahuje všechny potřebné
informace. Fireworks si do něho ukládají veškerá nastavení dokumentu včetně vrstev,
rámečků, efektů atd., aby s nimi mohl uživatel dále nerušeně pracovat po opětovném
otevření dokumentu. Ukládání probíhá skrze menu File>Save, případně File>Save As...
pokud chceme soubor uložit pod jiným jménem, nebo File>Save a Copy... pro uložení
kopie dokumentu do jiného souboru.

V každém případě se otevře dialogové okno, kam zadáme název dokumentu
a zvolíme umístění v adresářové struktuře.

V situaci, kdy chceme dokument uložit do jiného formátu nebo společně vytvořit
i doprovodný HTML a JavaScript kód používáme EXPORT (viz kapitola Export
dokumentu).

Vektory versus bitmapy

Vektorová grafika

Ačkoli Fireworks umějí editovat grafiku bitmapovou, většina naší práce bude spočívat
v grafice vektorové. Ta pracuje také s  body, ale hlavně s úsečkami a křivkami, které
jsou v počítačovém světě reprezentovány uzlovými body (viz Bezierovy křivky na konci
této kapitoly). Jednotlivé úsečky nebo pospojované úsečky či křivky se nazývají cesty
(path), místa spojení jsou uzlové body. Cesta je v podstatě sled bodů propojených
úsečkami nebo křivkami.
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Cesty můžeme rozdělit na cesty otevřené, kde počátek a konec jsou dva různé body
(např. křivka), a cesty uzavřené, které mají počáteční a cílový bod totožný (např.
čtverec).

Cesta otevřená a uzavřená

Další důležitý pojem k pochopení následujícího výkladu je Objekt. Tím je každý
logický celek na plátně, tedy jednotlivě každá cesta, bod, bitmapa, text atd. Objektem
chápeme také sjednocené objekty funkcí Group nebo spojené funkcí Join.

   

Objekty spojené funkcí Group a Join

Každý objekt, reprezentovaný pouze cestami nebo jednotlivými body, se nazývá kostra
objektu.

Ve Fireworks probíhá výpočet vektorové grafiky (přesněji křivek) stejně jako
v jiných editorech podle Bezierových křivek, což je matematická metoda, která využívá
k reprezentaci křivky čtyři uzly (body). Krajní body, které jsou krajními body křivky
(oblouku) a dva body vnitřní řídící její tvar (handlers — ovladače). V Macromedia
Fireworks je nejlépe tato metoda pozorovatelná při použití nástroje Pen (pero), kde
všechny čtyři body zadává sám uživatel a řídí tak průběh křivky.
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Bitmapová grafika

Bitmapová grafika tvoří pouze malou avšak nezanedbatelnou část editace ve Fireworks.
Jak je obecně známo, bitmapová grafika je založena na bázi bitové mapy neboli sítě,

kde každý bod je malý čtvereček (pixel = picture element = jeden elementární bod
obrazu), který má přiřazenou barvu a stálou a neměnnou polohu definovanou
souřadnicemi X a Y. Bitmapy, jak se jinak bitmapovým obrázkům říká, editujeme
prakticky bod po bodu a ve Fireworks jsou k tomu určeny pouze některé nástroje viz
Kreslení bitmapové grafiky.

Vybírání a označování objektů

Jelikož se vektorová grafika skládá z jednotlivých objektů, které můžeme nezávisle na
sobě upravovat přesouvat přidávat nebo odstraňovat, tak musí existovat možnost, jak se
na jednotlivé prvky odkázat, jak označit, že pracujeme právě s tou či s jinou strukturou.
K takovým účelům slouží nástroje jednotně nazývané „šipky“. Ve Fireworks jsou tyto
šipky dvě — černá (Pointer, neboli ukazovátko), jejíž součástí jsou i nástroje Select
Behind (výběr v pozadí) a Export Area (export vybrané oblasti) a šipka bílá (Subselect).

Označení (vyselektování) objektů nástroji se projevuje zvýrazněním kostry jinou
barvou. Implicitně je nastaveno bleděmodré zbarvení, což je možné změnit v nastavení
programu Fireworks (File>Preferences...) položkou Highlights. Pokud zvýraznění
objektů působí rušivě, nabízí se nastavení View>Hide Selection, které zajistí skrytí
„highlights“ okamžitě po označení objektu.

Výbornou vlastností Fireworks je citlivost při samotném výběru. Pokud totiž
označujeme cesty jednotlivě nástroji Pointer, Subselect či Select Behind, každá kostra
se po přiblížení se kurzorem zvýrazní sitě červenou barvou a zpřehlední nám tak hustě
pokreslená místa na plátně. Tuto vlastnost lze nastavit u těchto tří nástrojů ve složce
Tool Options jako Mouse Highlights spolu s atributem Preview Drag, který zajišťuje že
je při přesunu objektů zobrazován tento objekt celý včetně výplní apod.

Pointer (ukazovátko)
Jak název napovídá, černou šipkou ukazujeme na objekty. Je možné vybrat (označit)
jeden nebo více objektů najednou a ty následně přesouvat stejným nástrojem.
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Varianty výběru:
Prosté označení objektu, cesty, bodu Kliknout na objekt
Označení jednotlivého objektu, cesty, bodu,
jako součásti seskupení (Group)

Klávesa ALT + kliknout na objekt

Označení objektu, cesty, bodu umístěným za
jiným objektem

Klávesa CTRL + kliknout na objekt

Označení více jak jednoho objektu
(vícenásobné označení)

Klávesa SHIFT + kliknout na další
objekt, možno objekty opakovaným
kliknutím odznačit

Označení více jak jednoho objektu
(výběr souvislou oblastí)

Stisknutím talčítka myši mimo objekt a
následným tažením vytvoříme oblast;
vybrány budou objekty dotýkající se
pomyslného obdélníku

Varianty přesunu:
Přesunout označené objekty, cesty, body Stisknutím myši na označeném objektu

a současným tažením
Přesný posun objektů, cest či bodů po
pomyslných vodících přímkách

Přesunovat se stištěnou klávesou
SHIFT

Vytvoření duplikátu objektu přetažením na
jiné místo

klávesa ALT + táhout objekt na jiné
místo

Select Behind (výběr v pozadí)
Je užitečným nástrojem při práci ve vrstvách, při překrývání jednotlivých objektů a také
při vytváření hotspot a slice objektů (viz Slice a Hotspots). Po zvolení této funkce lze
vybírat postupně objekty ležící v zákrytu nebo v jiných vrstvách od nejvyšších až po
nejnižší bez nutnosti přesunu nebo přepnutí do jiné pracovní vrstvy (viz Vrstvy).

Subselect (podvýběr)
Bílá „šipka“ funguje obdobně jako Pointer. Její specifickou vlastností je označení
kostry objektu a zároveň i uzlových bodů cest. Vybrané uzly nebo úsečky pak můžeme
nástrojem Subselect modifikovat (přesouvat, mazat uzlové body, měnit tvar křivek
apod.). Ve sjednocených objektech umožňuje pracovat individuálně s prvky skupiny
kliknutím na její prvek.
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Zobrazené označení nástrojem Subselect Tool

Export Area (export vybrané oblasti)
Pokud se rozhodneme exportovat do nového souboru pouze výřez našeho obrázku,
vybereme otímto nástrojem blast určenou pro uložení. Tu můžeme také upravit pomocí
vodících čtverečků nebo přesunout a potom exportovat dvojklikem do výběru nebo
stisknutím tlačítka Export v Tool Options. Vlastnosti uložení výřezu se nastavují
v dialogovém okně, které se následně otevře. Vysvětleno bude v kapitole Export
dokumentu.

Kreslení vektorové grafiky

Hned na začátku je potřeba uvést, že vždy když začínáme pracovat na novém plátně
nebo na nově otevřeném dokumentu, jsme automaticky přepnuti do módu pro editaci
vektorové grafiky. Jedinou vyjímku tvoří pouze dokumenty, které před otevřením byly
pouze bitmapové obrázky. To se pak okamžitě nacházíme v módu pro editaci
bitmapových objektů, o kterém bude řeč v kapitole Kreslení bitmapové grafiky, a který
rozeznáme podle toho, že kolem okrajů nebo pravítek otevřeného dokumentu je
zvírazněna pruhovaná černomodrá linka.

Kreslící nástroje

Nástroje pro kreslení základních linií jsou Line (linka), Pen (pero), Pencil (tužka)
a Brush (štětec). Další rozšiřující nástroje schopné kreslit celé geometrické tvary
(uzavřené cesty) jsou Rectangle (obdélník, čtverec), Ellipse (kružnice) a Polygon.
Některé z těchto nástrojů mají své specifické vlastnosti, které se nám po poklepání na
nástroj zobrazí v záložce Tool Options, kde je můžeme následně měnit podle libosti.
U takových budou možná nastavení vždy uvedena.
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Line (linka)
Tento nástroj vytváří běžné úsečky popřípadě body. Stisknutím tlačítka a následným
tažením se zobrazuje předběžná výsledná linka. Při jednoduchém kliknutí nakreslíme
jeden bod.

Pen (pero)
Perem jsme schopni vytvářet dokonalé křivky či lomené čáry, u kterých můžeme
jednotlivými uzlovými body různě manipulovat, tyto body přidávat nebo naopak ubírat.
Pokud pouze klikáme perem na různá místa plátna, vytváříme nekonečnou lomenou
čáru, kterou zakončíme dvojitým poklepáním do stejného bodu nebo kliknutím do bodu
počátečního, čímž vytvoříme uzavřenou cestu.

Je však možné nakreslit i ladnou křivku tím, že v počátečním bodě stiskneme tlačítko
myši a pohybem vytvoříme pomyslnou vodící přímku (ta se nám zobrazuje pouze
dočasně), nebo spíše první (1) a druhý (2) uzlový bod, kde první je počátek křivky. Po
uvolnění tlačítka ve zvoleném bodě můžeme vybrat cílový bod (3) naší křivky a
následně další uzlový bod (4) ovlivňující stejně jako ten druhý průběh křivky. Křivku
můžeme buď dále rozvíjet nebo zakončit stejným způsobem jako lomenou čáru.

Křivka s uzlovými body nakreslená nástrojem Pen

Při kreslení perem se v určitých situacích v blízkosti kurzoru objevují různé drobné
symboly informující o případných možnostech pera. Jejich význam je následující:

Kliknutím myši začne pero kreslit novou cestu

Kliknutím uzavře kreslenou cestu (vytvoří uzavřenou cestu)

Kliknutím vloží uzlový bod na existující cestu
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Upravíme či vytvoříme uzlové body křivky

Následujícím kliknutím nenakreslíme nic, označíme bod
existující

Pencil (tužka)
Používá se k editaci po jednotlivých bodech, nebo k přirozenému kreslení cest tzn. „od
ruky“. Pokud je takto vytvořená cesta nerovná, program automaticky doplní uzlové
body křivky. U tohoto nástroje můžete v Tool Options nastavit zda se bude čára opticky
zarovnávat, tedy mírně rozmazávat (Anti-Aliased). To jim dodá přirozenost vzhledu.
Tužkou nelze rozšiřovat a měnit tvar již existujících cest.

Brush (štětec)
Štětec funguje téměř stejně jako reálný malířský štětec. Pracuje se sním stejně jako
s tužkou, pouze s tím rozdílem, že můžeme předem nastavit výsledný tvar stopy
v záložce Stroke (viz kapitolu Vzhled objektů). Ten je také závislý na rychlosti tahu
štětce resp. myší. To znamená, že čím rychleji štětcem pohybujeme po plátně, tím slabší
je tlak a tedy intenzita a šířka stopy.

Obrázek stopy štětce

Rectangle (obdélník)
Obyčejný a přesto velmi používaný nástroj pro tvorbu pravoúhlých objektů, tedy
čtverců (se stisknutou klávesou SHIFT) a obdélníků. Kreslíme stisknutím myši
a následným tažením libovolným směrem. Při podržení klávesy ALT objekt „roste“
souměrně ze svého středu. Klávesy ALT a SHIFT je možné kombinovat.

V Tool Options je možné také číselně nastavit velikost zaoblení rohu (Corner)
v radiánech.
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Obdélník se zaoblenými rohy nakreslený nástrojem Rectangle

Ellipse (elipsa)
Tento nástroj používáme stejně jako Rectangle. Klávesy ALT a SHIFT fungují
obdobně.

Polygon
Polygon je rozšíření nástroje Rectangle. Mnohoúhelníky se vždy vykreslují od středu,
což usnadňuje jejich umístění.

Důležité jsou vlastnosti (Tool Options), kde můžeme v pop-up menu nastavit, zda
chceme vykreslovat polygon nebo hvězdu (Star). U obou možností lze zvolit počet stran
nebo vrcholů (Sites) od 3 do 25 a pro hvězdu nastavujeme ještě úhel ostrosti hrotu ve
stupních od 0 do 100, pokud zaškrtneme položku Automatic, úhel bude vždy
automaticky přednastaven.

Kreslení bitmapové grafiky

Mód editace bitmapové grafiky se vyznačuje zesílením okrajů plátna černou
pruhovanou linkou. Vytvoření bitmapového objektu dosáhneme několika způsoby, do
módu editace takového objektu vstoupíme vždy dvojklikem na objekt.
• Otevření existujícího pouze bitmapového souboru, tedy formátu JPG, GIF, TIF, PCX

atd.
• Importování bitmapového obrázku ze souboru na plátno (File>Import...,

Insert>Image...).
• Vytvoření vlastního nového bitmapového objektu (Insert>Empty Image).
• Vytvoření bitmapy z vektorového objektu Modify>Merge Images.
• Okopírováním z jiného místa či aplikace metodou Drag&Drop.
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Naopak pro návrat zpět k vektorovému módu lze použít
• Dvojklik na prázdné místo dokumentu libovolným výběrovým nástrojem (Pointer

atd.).
• Kliknutí na tlačítko STOP na stavovém řádku (na dně obrazovky).
• Menu Modify>Exit Image Edit.
• Stisknutí klávesy ESC.

Mód editace bitmapy

Nástroje použitelné při kreslení bitmapy jsou Line, Pencil, Brush, Rectangle, Ellipse,
Polygon a Fill. Jejich vlastnosti a funkce jsou naprosto stejné jako při kreslení grafiky
vektorové, jen s tím rozdílem, že nevytváříme nejprve cesty a na ty pak aplikujeme
úpravy skrze inspektory, ale rovnou kreslíme přednastavenými nástroji s jejich
definitivní stopou a charakterem (viz kapitola Vzhled objektů). Tzn. že to co nakreslíme
je dále neupravitelné, neměnné, můžeme pouze překreslovat, mazat, kopírovat.
Speciálními nástroji jsou Marquee, Ellipse Marquee, Lasso, Polygon Lasso, Magic
Wand, Eraser a Rubber Stamp. Zvláštním nástrojem je Crop použitelný i ve
vektorovém módu.

Označování oblastí v bitmapové grafice

Tyto nástroje mají podobné vlastnosti a společně slouží k vyselektování požadované
oblasti bitmapy.

 
Marquee a Elliptical Marquee
Nástroje Marquee a Elliptical Marquee vybírají geometrické oblasti a mají stejné
vlastnosti v Tool Options panelu, kde je možné nastavit chování okrajů oblasti (Normal,
Fixed Ratio — stálý poměr stran oblasti, Fixed Size — fixní rozsah oblasti v bodech)
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a prolínání výběru do okolí (Anti-Alias — mírné rozostření okrajů, Feather — plné
prolnutí do okolí s nastavením meze v bodech).

 
Lasso a Polygon Lasso
Prolínáním oblasti do okolí disponují i nástroje Lasso a Polygon Lasso, které navíc
nabízejí alternativu Hard Edges — ostré okraje oblasti, potlačení prolínání. Vybíráme
s nimi tvarově volnou a polygonální oblast.

Magic Wand
Zcela odlišným nástrojem pro výběr oblasti je nástroj Magic Wand. Tu použijeme
tehdy, když vybíráme oblasti podobné barvy. V záložce Panel Options nastavujeme
hlavně toleranci (Tolerance), se kterou k výběru dochází. Hodnota této veličiny
definuje, kolik barevně vzdálených odstínů od původně zvolené barvy pixelu bude
zahrnuto do výběru.

Držením klávesy SHIFT k vybrané oblasti přidáváme další oblast, klávesa ALT oblast
odebírá. Kombinací SHIFT+ALT vybírá pouze části již vyselektovaných oblastí. To
platí pro všechny nástroje této skupiny.

Co se týče označování oblastí bitmapové grafiky, nabízí Fireworks i další alternativy
výběru oblasti.
Funkce Edit>Select Inverse inverzně označí zbytek obrázku podle předem
vyselektované oblasti, Edit>Select Similar vybere celou souvislou oblast barevně
podobnou původnímu označení.

Crop (oříznutí)
Crop je nástroj s jednoduchou funkcí oříznutí zbytečné plochy plátna. Podobně jako
když Pointerem vybíráme objekty souvislou oblastí, nakreslíme čárkovaný obdélník
ohraničující plochu, kterou chceme ponechat. Jeho velikost lze měnit tahem čtverečků
umístěných na hranách, polohu pak přetažením celé oblasti. Poklepáním uvnitř výběru
nebo stisknutím tlačítka Crop v Tool Options uskutečníme samotné oříznutí.

Vytvoření čtvercové oblasti dosáhneme držením klávesy ALT.
Pokud takto označíme oblast na bitmapovém obrázku, máme na výběr dvě možnosti.

Buď ořízneme pouze zbytek obrázku (Edit>Crop Selected Image) nebo rovnou celý
dokument (Edit>Crop Ducument).

S editací bitmapy souvisí i úprava rozměrů plátna podle velikosti pokreslené plochy.
Pokud totiž budeme editovat bitmapu nebo označíme Image (bitmapový) objekt
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a zvolíme Modify>Document>Trim Canvas, oøízeneme celý dokument podle tohoto
obrázku.

Editační nástroje

Eraser (guma)
Guma má stejné praktické využití jako v reálném světě. Tool Options definují její tvar
(kruh, čtverec), velikost v bodech a rozostření. Dalšími nastaveními je barva, kterou
bude Eraser gumovat (Transparent — průhledně, Fill Color — barvou výpně, Stroke
Color — barvou štětce, Canvas Color — barvou pozadí).

Rubber Stamp (razítko)
Je speciálním nástrojem, který přirozeně kopíruje části obrazu přesně podle námi
vedeného razítka. Po vybrání tohoto nástroje klikneme na libovolné místo obrazu, kde
se zobrazí modře ohraničený kruh, který bude vzorem (matricí) pro kopírování.
Následným kreslením na jiném místě pohybujeme jak razítkem (kurzorem), tak touto
matricí a kopírujeme její obsah. Nové umístění matrice lze nastavit novým zvolením
nástroje nebo kliknutím spolu s klávesou ALT.

Tool Options nabízejí:
Source: Fixed — matrice je ve stále stejné poloze a vzdálenosti od kurzoru.
Source: Aligned — matrice je nastavena po uvolnění tlačítka myši vždy na původní
místo (vhodné pro kopírování části obrazu na více míst).
Sample: Image — kopíruje pouze z oblasti editovaného Image objektu (bitmapy).
Sample: Document — kopíruje libovolnou část dokumentu.
Velikost a rozostření (Stamp) razítka.

Užitečnou funkcí je i spojení několika vyselektovaných bitmapových objektů v jeden
přes menu Modify>Merge Images.

Další speciální efekty týkající se bitmapové grafiky se nacházejí v menu Xtras, které
jsou obdobou filtrů editoru Adobe Photoshop. Aplikují se po vyselektování
bitmapového objektu nebo jeho části a jejich použití záleží na zkušenostech každého
uživatele.
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Písmo ve Fireworks

Stejně jako v každém jiném vektorovém editoru, jsou i Fireworks vybaveny nástrojem,
pomocí něhož vkládáme text do dokumentu.

Text tool (psaní)
Po klepnutí tímto nástrojem na plátno vkládáme do obrazu text, který se chová jako
samostatný nedělitelný objekt. Otevře se dialogové okno (Text>Editor...), kde
editujeme text a vlastnosti písma. Již vytvořený text lze opět editovat poklepáním nebo
kliknutím stejným nástrojem.

Interní textový editor

Pokud v textovém okně zaškrtneme políčko Apply, automaticky se budou projevovat
námi provedené změny rovnou na plátně.

Anti-alias způsobuje optické rozostření okrajů písmen a dodává tak plynulost
přechodu mezi písmem a pozadím.

Auto-kern zajistí automatické nastavení rozestupu písmen při změně velikosti
textového okna. Vytvořený text se totiž chová jako samostatný objekt a po jeho
označení se zobrazí pravoúhlý obrys spolu s ovladači (malé čtverečky po obvodu), jimiž
lze pohybovat a tak tvar dodatečně upravovat.
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Textový objekt s ovladači

Text na křivce

Specialitou vektorových editorů bývá kombinace textu s cestou (křivkou). I Fireworks
disponují funkcí, kterou logicky přidruží libovolnému textovému objektu cestu (křivku).
Písmo pak přesně kopíruje průběh křivky.

Text umístěný na křivce

Takového efektu dosáhneme následovně:
1.  Nakreslíme libovolnou křivku nebo úsečku a vytvoříme text, který chceme k cestě

připojit.
2.  Oba tyto objekty dohromady označíme.
3.  Zvolíme menu Text>Attach To Path.
Případně můžeme zvolit orientaci textu na úsečce (Text>Orientation...) a nastavit
reverzní výpis textu (Text>Reverse Direction).
Text zpátky od pøímky oddìlíme volbou Text>Detach From Path.

Transformace písmen na vektorové objekty

Zajímavá a u�iteèná je i funkce umo�òující nám pohlí�et na obyèejný text jako na
vektorový objekt slo�ený z cest. Pokud pou�ijeme na libovolný text volbu
Text>Convert To Path celý označený převedeme na objekt, který už není možné
editovat textovým editorem. Lze ho však rozložit funkcí Ungroup (Modify>Ungroup)
na jednotlivá
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písmena a pracovat s nimi stejně jako s jinými objekty vytvořenými například nástrojem
Pen (pero).

Tool Options obsahují pro Text Tool pouze jedinou volbu, kterou je Revert To Pointer,
po jejím� zaškrtnutí je okam�itì po editaci (uzavøení textového okna) aktivován
nástroj Pointer. Vhodné zvláš� tehdy, pokud chceme okam�itì textový objekt dál
pøesouvat nebo upravovat pomocí ovladaèù.

Nástroje pro úpravu objektů

Vektorová grafika je díky své struktuře a nezávislosti jednotlivých prvků snadno
modifikovatelná. Nástroje, se kterými Vás nyní seznámím jsou určeny k úpravě cest,
což je důležité, neboť nezáleží tolik na konečném vzhledu, ale hlavně na tvaru tvořícím
podklad každého objektu.

Modifikační nástroje ve Fireworks jsou Freeform (vlastní forma), Reshape Area
(změna tvaru), Path Scrubber, Redraw Path (překreslení cesty) a Knife.

Freeform (vlastní forma)
Freeform používají návrháři, kteří chtějí modifikovat cestu volně a přirozeně bez ohledu
na pravítka, úhly a další geometrická pravidla. Jednoduše od ruky mění tažením či
tlačením chrakter cesty.

Použití Freeform je následující:
• Označíme si cestu, kterou chceme modifikovat a zvolíme nástroj Freeform

Poté máme na výběr dvě možnosti:
• Kurzorem najedeme na zvýrazněnou cestu, tím se vedle něho objeví písmeno S.

Stisknutím tlačítka myši a tažením upravujeme tvar cesty přímo. Toto je úprava
„tahem“.

• Nebo tlačítko myši stiskneme mimo označenou cestu, čímž se kurzor změní
v kružnici. Jejím obrysem pak prohybáme tvar cesty, stejně jako bychom například
chtěli mincí pokroutit nit na stole. Tento způsob je úprava „tlakem“.

V Tool Options je možné nastavit položku Size, tedy průměr této kružnice. Přímo při
práci, kdy držíme stisknuté tlačítko myši a chceme třeba vytvarovat cestu do
pravidelného oblouku, nebo rychle měnit velikost kružnice, jsou k dispozici klávesy 1,
2 resp. šipka doleva, šipka doprava, které průměr zmenšují resp. zvětšují o 1 bod.
Rozmezí je od 1 do 500 bodů.
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Úprava křivky nástrojem freeform — tlakem

Dalšími parametry Freeform v Tool Options jsou Pressure způsobující citlivost
vytvářeného tlaku na cestu, což je prakticky využitelné pouze při práci s tabletem
citlivým na tlak a Preview zobrazující výsledné zakřivení již při úpravě.

Stisknutá klávesa Shift nastavuje pohyb kurzoru po 45° přímkách.

Reshape Area (změna tvaru)
Podobně jako Freeform upravuje průběh cesty, ale pouze metodou „tlaku“. Má však
několik specifických vlastností, které rozšiřují schopnosti nástroje. Je vhodný hlavně při
práci s tabletem, neboť zahrnuje možnost ovládání vlastností Size (velikost) a Strength
(síla) rovnou tlakem vynaloženým na pero. Ale to pouze tehdy pokud zvolíme obě tyto
možnosti v Tool Options v okénku Preasure. Size je opět průměr kružnice (1—500
bodů), Strength (1—100%) je síla, kterou působí nástroj na cestu. Obě veličiny jsou při
práci vyjádřeny jako soustředné kružnice, kde vnitřní je síla a vnější pak vlastní
velikost.

Klávesy 1, 2 a Shift pracují stejně jako u nástroje Freeform.

Path Scrubber (+/-)
Předchozí dva nástroje se týkali pouze tvaru vytvářených objektů, tedy cest a koster.
Naproti tomu jsou  Path Scrubber(+/-) nástroje, které upravují pouze vzhled
nakreslených èar. Lépe øeèeno upravují tlak a rychlost, jakými byly nakresleny.

Pro struèné vysvìtlení uvedu jednoduchý pøíklad, samotnou problematikou
upravování vzhledu cest, bodù a objektù se budu zabývat v samostatné kapitole.

• Zvolíme nástroj štìtec (Brush Tool).
• V zálo�ce Stroke (Window>Stroke) nastavíme jeho typ — první pop-up menu

nastavíme na Calligraphy, což je druh štětce užívaný pro písmomalířství a na němž
je výsledný efekt obzvlášť patrný.
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• Potom na plátno prudkým tahem nakreslíme libovolnou čáru. Výsledkem bude
ztenčující se linka. Právě na té je patrná rychlost tahu štětce. Samozřejmě, že tyto
nástroje se velmi efektně používají při práci s tabletem, neboť pouze s ním jsme
schopni kreslit rychle a zároveň i relativně přesně.

• Pokud efekt není patrný je možné změnit buď barvu štětce na panelu nástrojů nebo
zvětšit hrot štětce (Tip Size — pop-up menu s označením kolmé oboustranné šipky
v záložce Stroke). Další chybou může být nastavení zobrazování Draft Display,
přepněte se tedy do modu Full Display (viz kapitola Toolbars).

Obrázek zesilující se linky v závislosti na rychlosti tahu

Na takto vytvořený objekt nyní můžeme aplikovat nástroj Path Scrubber:
• Pokud není cesta označena tak ji vybereme a nástrojem Path Scrubber (+/-)

přidáváme/ubíráme na objemu čar v různých úsecích podle potřeby.
• V Tool Options nástroj disponuje třemi položkami. Pokud zaškrtneme Preasure, je

nám umožněno měnit tlak, tedy lokální tloušťku linky. Zaškrtnutím Speed
upravujeme rychlost, tedy plynulé zeslabování resp. zesilování linky. Kvanta, po
kterých přidáváme nebo ubíráme z objemu čáry nastavíme v okénku Rate (šířka od 1
do 10 bodů).

Pro pohodlnost takové editace je možné přepínat mezi nástroji Path Scrubber(+) a Path
Scrubber(-) podržením klávesy Alt.

Redraw Path (překreslení cesty)
Velmi užitečný nástroj, který využijeme, pokud chceme stávající cestu rozšířit nebo
překreslit.

Návod na jeho použití je velmi jednoduchý:
• Vyberte cestu k upravení a zvolte nástroj Redraw Path
• Pokud chcete rozšířit cestu na jejím konci, stačí na tento konec ukázat kurzorem.

Tím se vedle malého štětečku objeví symbol + a Vy můžete začít kreslit s tím, že se
nově vytvořená cesta automaticky připojí k Vámi zvolenému objektu.

• Pokud však chcete cestu rozšířit od prostředku (nahradit část cesty), musíte ukázat na
místo, odkud chcete stávající cestu rozdělit. Tam se zobrazí vedle kurzoru malá šipka
a tak můžete začít kreslit novým směrem. Zároveň se zbytek cesty (menší část)
označí červeně. Když se pak vrátíte na libovolné místo původní cesty a pustíte
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tlačítko myši,
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tak se cesta mezi počátečním a cílovým bodem vymaže a nahradí se Vámi
nakreslenou čarou. Ale jestliže přestanete kreslit mimo původní cestu, červeně
označená část bude odříznuta a nahrazena novou (viz obrázek).

Překreslení cesty nástrojem Redraw Path

Knife (nůž)
Nůž slouží stejně jako reálný nůž s tím rozdílem, že neřeže provázek, ale cestu.

Označíme objekt resp. jeho kostru, vybereme nástroj Knife a stisknutím myši
v počátečním bodě řezu, tažením napříč kostrou a uvolněním v cílovém bodě řezu,
definujeme úsečku řezu. Ta automaticky rozdělý daný objekt na dva či více nezávislých
objektů.

Rozdělení objektů nožem (Knife)
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Pomocné nástroje

Hand (ruka)
Velmi jednoduchý nástroj. Posouváme jím plátno po pracovní ploše, pokud není celé
viditelné.

Magnify (lupa)
Klasický nástroj pro zmenšování či zvětšování zobrazení plátna. Nastavení zobrazení
lze ovládat skrz menu View:
• Magnification — procentuelní zvětšení resp. zmenšení
• Zoom In/Zoom Out — zvětšit/zmenšit
• Fit All — nastavit zvětšení odpovídající velikosti obrazovky (viditelný celý obraz)
• Fit Selection — nastavit zvětšení výběru na celou obrazovku (viditelná celá oblast)

Pravým tlaèítkem myši zobrazíme menu, kde jsou stejné volby.
Praktická rada: poklepáním na ikonu nástroje se zobrazení nastaví na 100%.

Eye Dropper (kapátko)
Nástroj pro výběr barvy z plátna a nastavení barvy výplně nebo linky podle označení
v panelu nástrojů.

V Tool Options nastavujeme 1Pixel pro výběr barvy jednoho konkrétního pixelu,
3x3Average resp. 5x5Average pro výběr průměrné barvy z oblasti 3x3 resp. 5x5 pixelů.

Po zvolení nástroje a kliknutím buď do oblasti barvy štětce/výplně na panelu
nástrojů, nastavujeme aktuální barvu přímo z plochy plátna.

Vzhled objektů

Nastavení barev

Přesto, že je vektorová grafika navrhována jako množina bodů, úseček, křivek atd., kde
základem je tvar, jejím druhotným  atributem je výstupní vzhled a tedy i barva. Její
působení v internetovém prostředí je velmi důležité a v podstatě je na ní založen www
design, protože správná kombinace barev má ohromný vliv na konzumenta
internetových
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stránek. V této kapitole Vás však nenaučím jak správně míchat a vybírat kombinace
barev, pouze ukáži jak vybrat barvu pro pero, podklad a jak vyplňovat prázdné plochy.

Barvu je možné měnit u již existujících objektů tím, že objekt vyselektujeme a poté
barvu změníme jedním z následujících způsobů, nebo barvu můžeme přednastavit a
poté kreslit objekty nové aktuálními barvami.

Okno pro rychlé nastavení barvy v panelu nástrojů

Pro rychlé nastavení barev slouží malé kolonky umístěné v dolní části Toolboxu. Pokud
klikneme na šipku vedle obdélníčku, který zobrazuje aktuálně zvolenou barvu, objeví se
okno s obsahem přednastavené palety

O málo detailnější pohled na nastavení barev nabízí panely Mixer a Swatches
(Window>Color Mixer/Swatches).

Mixer je obdoba palety windows pro vytvoření vlastního odstínu. Jedinou odlišností
je způsob numerického zadávání barvy — šipka v pravém horním rohu inspektora
otvírá nabídku. Na výběr jsou numerické typy, jejichž specifikace je uvedena
v následující tabulce.

Typ Popis
RGB Zastoupení tří základních barev červené, zelené a modré, kde každá

barva má rozmezí od 0 do 255. Pro černou barvu je zápis 0-0-0, pro
bílou 255-255-255. Vychází ze základních barev luminiscenčních látek
obsažených v bodech monitoru.

Hexadecimal Stejný zápis jako RGB, ale číselným vyjádřením v šestnáctkové
soustavě v rozmezí od 00 do FF.
Typ: Pro vytvoření bezpečných internetových barev, o kterých bude
řeč, používejte kombinace těchto dvojčíslí: 00, 33, 66, 99, CC, FF.
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Typ Popis
HSB Vyjádření třemi vlastnostmi barvy — Hue (odstín), Saturation (sytost)

a Brightness (jas), kde odstín nabývá hodnoty 0—360 stupňů a sytost a
jas hodnoty 0—100%. Toto vyjádøení je známé z bitmapovì
zalo�ených editorù napø. Adobe Photoshop.

CMY Podobné jako RGB s tím rozdílem, že tři základní komponenty jsou
barvy cyan (tyrkysová), magenta (fialová) a yellow (žlutá) — odtud
název zápisu.
Černá barva — 255-255-255, bílá — 0-0-0

Grayscale Toto vyjádření je pouze procentuelní zastoupení černé v černobílém
spektru, kde 0% je barva bílá, 100% je barva černá a mezi jsou odstíny
šedé.

Okamžité numerické vyjádření barvy, nad kterou se ocitá kurzor, lze kontrolovat
v záložce Info (Window>Info).

Swatches jsou barevné palety. Tato záložka nabízí několik palet, které mají své
specifické vlastnosti. Ve Fireworks jsou čtyři vestavěné palety (volby jsou zobrazovány
v pop-up menu v pravém horním rohu záložky): Web 216 Palette, Windows System,
Macintosh System a Grayscale.

Palety Windows a Macintosh System jsou palety určené speciálně pro jmenované
systémy. Pro tvorbu webovské grafiky je však vhodnější volit paletu Web 216 Palette,
která je jinak také nazývána Web-Safe nebo Browser-Safe, tedy bezpečná paleta pro
totožné zobrazování na různých platformách. Paleta Grayscale obsahuje pouze odstíny
šedi.

Palety si můžete Vytvářet vlastní nebo je kopírovat ze souborů typu GIF, různě je
rozšiřovat a ukládat pro příští použití. Vytvářet palety vlastní je obzvlášť vhodné, pokud
navrhujeme internetovou stránku v určitých odstínech.

Při konečných exportech vytvořených obrázků do formátu GIF případně
AnimatedGIF je ukládána do těchto souborů také jejich paleta. Proto je dobré paletu
upravit tak, aby v ní byly pouze barvy, které výsledný obrázek skutečně obsahuje.

Volby pop-up menu v záložce Swatches
• Add-swatches — přidává barvy ze souboru, buď ze souboru s obsahem palety

(*.act), nebo ze souboru typu *.gif.
• Replace-swatches — nahrazuje celou paletu ze souboru (*.act, *.gif)
• Save-swatches — ukládá vytvořenou paletu do souboru typu *.act
• Clear-swatches — maže stávající paletu a dává prostor k vytvoření nové palety
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Stroke — definování linky

Panel Stroke (Window>Stroke) slouží k úpravě vzhledu vymodelovaných cest. Každou
zvlášť označenou cestu je tedy možné upravit jinak podle libosti. Při definování
vlastností však nedefinujeme pouze vzhled již vytvořených objektů, ale zároveň
nastavujeme kreslící nástroj pro malování nových objektů. Na výběr je opravdu hodně
kombinací.

Panel Stroke pro úpravu vzhledu čar

Editace vlastního efektu je relativně náročná a je k ní potřeba osobních zkušeností
v práci s jednotlivými materiály. Nebudu tedy vysvětlovat jak si vytvořit efekt šitý na
míru, ale pouze naznačím postup.

Po zvolení položky Edit Stroke... se otevře dialogové okno se třemi záložkami:
Options, Shape, Sensitivity.
• V záložce Options volíme vlastnosti inkoustu (Ink), jeho texturu (Texture) a počet

kreslících hrotů a jejich vlastnosti (Tip).
• Záložka Shape definuje tvar samotného hrotu včetně sklonu pera a tedy i tvar

výsledné linky.
• Poslední záložka Sensitivity nejpřesněji upravuje fyzické vlastnosti pera jako je sklon

(Angle) a šířka (Size) a optické vlastnosti inkoustu — světlost (Lightness), sytost
(Saturation) apod.
Výsledný efekt záleží značně na zkušenostech a také na náhodě, se kterou

k požadovanému vizuálnímu efektu dospějeme. Výhodou těchto návrhářů je, že
obsahují tzv. Preview — malé okno, kde se okamžitě zobrazuje výsledek experimentů.
Důležité je uložit si originální efekt (Save Stroke As...) a přiřadit mu nezaměnitelné
jméno, aby mohl být i napříště použitelný (uloží se do pop-up menu Typ na panelu
Stroke pod materiál, který jste upravovali).
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Fill — definování výplně

Panelem Fill (Window>Fill) definujeme výplň objektů. Cesty ani nemusí být uzavřené,
vyplnit nelze pouze úsečky. V této kapitole bude vysvětlena i funkce nástroje Paint
Bucket z panelu nástrojů, který objekty přímo vyplňuje.

Panel Fill pro nastavení vzhledu výplně

Kategorie — kategorie můžeme rozdělit na dvě části, protože i v programu jsou opticky
odděleny vodorovnou čarou. První skupinou jsou následující varianty:
• None — objekt bez výpně.
• Solid — objekt s jednobarevnou výpní.
• Web Dither — skládaná výplň, založená na bázi tzv. ditheringu, což je metoda

skládání barevného odstínu ze dvou základních barev Web-Safe palety. Tato výplň je
určena pro internetovou grafiku, protože pomocí této techniky je možné namíchat
mnohem více odstínů než umožňuje bezpečná paleta pro stejné zobrazování na
různých platformách. Pro takovouto výplň můžeme zajistit zaškrtnutím položky
transparent průhlednost.

• Pattern — výplň nastavitelným vzorem.

Druhá skupina Kategorie obsahuje varianty, které mají společnou vlastnost:
Gradient. Jsou to typické výpně, kdy jedna barva plynule přechází do druhé případně do
třetí, čtvrté atd. Stačí vybrat tvar a druh výpně. Každý gradient je možné velmi
jednoduše editovat:

V menu panelu vybereme Edit Gradient a otevřeme tak dialogové okno pro jeho
úpravu, která je velmi jednoduchá. Stačí pouze vybrat barevné schéma a pak posouvat
barevné linie. Výsledek si můžeme uložit (Save Gradient As...), případně ho
přejmenovat (Rename), smazat (Delete).
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Typ výplně — toto pop-up menu nabízí další odrůdy jednotlivých kategorií.
Hard Edge — je ostré ohraničení přesně podle obrysu objektu (vektorových cest).
Anti-Alias — mírně opticky „rozmazává“ okraje výpně.
Feather — ignoruje hranice objektu a doznívá za jeho okraji podle procentuelního
nastavení.

Stejně jako při úpravě čar, i u výplní je možné nastavit texturu a její procentuelní
intenzitu.

Paint Bucket (výplň)

Vlastnosti nástroje Paint Bucket jsou definovány v záložce Fill, proto jeho funkce
uvádím až zde. Pokud definujeme vlastní výplň, nebo použijeme výplň vestavěnou,
nastavujeme tak zároveň i vlastnosti tohoto nástroje.

Při úpravě vytvořeného objektu není nutné objekt vždy označit, stačí pouze vybrat
nástroj Paint Bucket a kliknout na objekt (uzavřenou cestu nebo křivku). Ten se
automaticky vyplní přednastavenou výplní v okně Fill.

Paint Bucket má však ještě další výhody. Pokud zvolíme z pop-up menu Kategorie
jakoukoli jinou výplň než „None“ (žádná)  nebo „Solid“ (jednobarevná), u kterých
samozřejmě není co upravovat, zpřístupní se nám další možnost, jak upravit vzhled
výplně konkrétního objektu. Dobře patrné je to na následujícím příkladu:

• Vytvořme libovolný obdélník (pro názornost raději větší) a v panelu Fill vyberme
kategorii Pattern a následně její typ Bricks Small (cihly malé).Jak je vidět v preview,
jedná se o zobrazení cihlové zdi a právě na tomto pravidelném pravoúhlém  vzoru je
možné pozorovat námi provedené změny.

• Nyní zvolme nástroj Paint Bucket a stiskněme tlačítko myši uvnitř připraveného
obdélníku a tahem (stále držíme stisknuté tlačítko) vytvořme provizorní ovladače
v podobě jedné případně dvou úseček na sebe kolmých (dle zvoleného nástroje —
viz obrázek).

Výplň objektu upravená ovladači nástroje Paint Bucket
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Ty pak po uvolňení tlačítka zůstanou viditelné, dokud nezvolíme jiný nástroj. Na těchto
ovladačích závisí podoba výsledné výplně. Ovladačemi měníme střed, sklon, úhel a
zvětšení. U některých kategorií jsou ovladače pouze dva.

Effect — originální vzhled

Panel Efekt (Window>Effect) nabízí dotvoření předem graficky upravených objektů
(Stroke a Fill) a jejich originální ztvárnění. Úpravy provedené tímto panelem jsou
prospěšné hlavně při navrhování různých tlačítek, banerů, ohraničení a jiných optických
vylepšení. Docílíte jím velmi rychle zajímavých výsledků, které byste ručně kreslili
několik hodin.

Panel Effect pro definici efektu

V pop-up menu panelu je k dispozici několik základních vestavěných efektů, které
můžeme okamžitě aplikovat a případně je upravit klinutím na ikonu (i). Nad jedním
objektem můžeme mít nadefinováno více efektů a ty podle potřeby v panelu Effect
zapínat nebo vypínat.

Námi upravený efekt si můžeme také pojmenovat, uložit nebo smazat pro další použití,
jak tomu bylo již u záložek Stroke a Fill.

Jediná rada pro vytváření efektů s tak širokými možnostmi je vytvořit několik
jednoduchých objektů a na nich zkoušet různé kombinace.
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Style — jednotný styl

Style panel (Winodw>Styles) slouží k zachování celkové úpravy a designu libovolného
objektu. Nemusí se však jednat pouze o námi vytvořený styl např. tlačítek, rámečků
apod. Fireworks totiž disponují škálou předdefinovaných zajímavých stylů, které
můžete okamžitě využít. Stačí označit objekt a v panelu Styles kliknout na vybraný styl.
Ten se okamžitě aplikuje na vzhled objektu a nadefinuje automaticky nastavení
v panelech Stroke, Fill a Effect. To Vám usnadní práci např. při vytváření podobných
tlačítek pro internetovou stránku.

Stávající styly lze upravovat, vytvářet z nich nové, mazat a případně importovat/
exportovat z/do souboru (pop-up menu v pravém horním rohu panelu).
Vlastní styl lze ale velmi snadno uložit vyselektováním upraveného objektu a zvolením
položky New Style... ze stejného pop-up menu.

Object — charakter objektu

Tento inspektor pracuje se všemi objekty a na jejich druhu záleží, jaké volby bude tato
složka obsahovat. Po označení objektu se v okně (Window>Object) zobrazí aktuální
vlastnosti, které můžeme následně měnit.

Osm druhů objektů, po jejichž vyselektování se okno Object více či méně liší jsou:
Path (cesta), Image (bitmapa), Text, Text On Path (text umístěný na křivce), Group a
Mask Group (skupina objektů), Symbol, Hotspot a Slice. Typ objektu je zobrazen vždy
při jeho označení v okně Object nad oddělující linkou.

Typy objektů a atributy panelu Object

Path (Cesta)
Označení „cesta“ zahrnuje všechny objekty složené pouze z koster. Změny nastavení
nejsou rozsáhlé.

Volby panelu Object:
Volba Funkce

Object Opacity Nastavuje procentuelní průhlednost okrajů i výpně
objektu
100% — neprůhledný, 0% — neviditelný

Blending Mode Nastavení prolínaní objektů



Macromedia Fireworks 3

102

Volba Funkce
Stroke Settings Tři alternativy zobrazení okrajů na kostře objektu:

uvnitř, na a vně kostry.
Draw Fill Over Stroke Po zaškrtnutí je výplň objektu překreslována přes

jeho okraje (Stroke)

Blending Mode je funkce nastavující druh průhlednosti. Docílíme tak působivého efektu
připomínajícího pohled skrz upravené sklo.

Vytvořme např. dva objekty — jeden bude bitmapa, druhý kruh s modrou výplní.
Umístíme kruh nad bitmapu, označíme pouze kruh a v panelu Object vybereme
Blending Mode. Výsledky jednotlivých alternativ budou následující.

         Normal                       Multiply                        Screen                        Darken

        Lighten                      Difference                         Hue                         Saturation

          Color                       Luminosity                      Invert                            Tint

Blending Mode lze efektně kombinovat s vlastností Opacity (průhlednost).
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Image (Bitmapa)
Importovaný bitmapový obrázek nebo objekt vytvořený v módu editace bitmapové
grafiky (viz Kreslení bitmapové grafiky).

Pro Image lze upravovat pouze atributy Opacity a Blending Mode (viz Path).

Text
Objekt vytvořený nástrojem Text (viz Písmo ve Fireworks).

Nabízí stejné úpravy jako objekt Path. Navíc je pop-up menu obsahující dvě metody
transformace textu — Transform as Pixels (jako body) a Transform as Paths (jako
cesty).

Text On Path (Text umístěný na křivce)
Alternativa objektu Text. Rozšiřující vlastností je pouze numerická hodnota Offset
reprezentující odsazení textu od počátku křivky v bodech.

Group a Mask Group (Skupina a Maska)
Skupina je objekt složený funkcí Group (Modify>Group). Chová se stejně jako objekt
typu Path.

Mask Group nebo maska je objekt složený z jednoho či více subjektů funkcí
Modify>Mask Group>Mask To Image/Path. Pokud vybereme dva objekty, nastavíme
jeden do popředí (Arrange>Bring To Front) a aplikujeme na ně tuto funkci, bude se
objekt (obrázek) v pozadí chovat jako podklad a objekt v popředí jako jeho maska.
Masku je možné chápat pouze jako řídící obrys (v panelu Object položka Mask: Path)
nebo jako jeho částečně průhlednou výplň (Mask: Image).

Obrázek maskovaný elipsou funkcí Mask To Path

Symbol
Objekty typu Symbol jsou základem pro vytváření animací (animovaných GIFů) ve
Fireworks. Problematika symbolů bude vysvětlena v kapitole Animace. Pro symboly lze
definovat pouze vlastnosti Opacity a Blending Mode (viz Path v této kapitole).
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HotSpot a Slice
Toto jsou velmi specielní objekty a proto budou popsány ve vlastní kapitole Vytváření
Hotspot a Slice objektů.

Transformace objektu

Scale, Skew a Distort (Transform)
S objekty lze nadále i po jejich vytvoření různě geometricky pracovat nástroji
Transform Tools — Scale (velikost), Skew (skosení) a Distort (zkroucení). Na výběr
jsou tyto a ještě další speciality jako otáčení a překlopení v menu Modify>Transform.

Když označíme objekt a zvolíme jeden z těchto nástrojů, zobrazí se čárkované
ohraničení objektu spolu s ovladači, kterými objekt transformujeme (viz obrázek).
Krajní ovladače vždy objekt otáčejí, sklápějí, roztahují apod., centrální je pak středem
otáčení a můžeme ho přesouvat podle potřeby.

Funkce nástrojů Transform

V dialogu Modify>Transform>Numeric Transform definujeme transformace numericky
pro přesnou úpravu objektu.
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Operace s cestami

Mezi transformace objektu můžeme zařadit i operace s cestami, které umožňují
existující kostry různě kombinovat a upravovat. Aplikují se vyselektováním vstupních
cest a vybráním po�adované operace v menu Modify>Combine/Alter Path>...

Operace Funkce Příklad
Union Spojí dvě uzavřené cesty v jednu

sjednocením, tedy do nové cesty zahrne
obrys obou objektů. Výplň a okraj bude
kopírována ze spodního objektu.

Intersect Nová cesta je průnikem uzavřených cest
vstupních. Výplň a okraj kopírovány ze
spodního objektu

Punch Výsledná kostra je zbytek, který zůstane po
odstřižení  objektu horního od objektu
spodního.

Crop Výsledkem je průnik dvou uzavřených cest
podobně jako Intersect.

Simplify Odstraňuje body z cesty, které nemají vliv
na její tvar. Zjednodušují cesty.

Expand Stroke Rozšíří stávající cestu o další obrys v určité
vzdálenosti a aplikuje funkci Join, čímž je
spojí a vytvoří jednotný objekt. Možné
rozdělit fcí Split.

Inset Path Zvětšuje či zmenšuje uzavřené cesty podle
zadávaných parametrů.

Použitím těchto operací ztrácí cesty všechny informace o tlaku a rychlosti pera (viz
Stroke — definování linky).
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Layers — vrstvy

Užívání vrstev je při navrhování v objektově orientovaných editorech téměř nezbytností
hlavně kvůli přehlednosti. Vrstvy si lze představit jako průhledné fólie na které je
možné kreslit a jsou umístěné nad sebou. Ve Fireworks 2 je organizace vrstev víceméně
ponechána na uživateli, pouze definuje jednu jedinou „neměnnou“ vrstvu, která je úplně
nejvýš. Jmenuje se Web Layer, je neustále přítomna a jsou do ní ukládány pouze
objekty typu Slice a Hotspot. Vrstvy jsou užitečné zejména při kreslení mnoha
překrývajících se objektů, nebo objektů příbuzných, kdy každou skupinu kreslíme do
jiné vrstvy. Např. do vrstvy „pozadí“ můžeme uložit podkladový obrázek, do vrstvy
„tlačítka“ umisťujeme tlačítka atd.

Objekty každé vrstvy můžeme dále organizovat — zvlášť patrné je to pokud se
překrývají — přesouváním před/za sebe (forward/backward) nebo do popředí/pozadí
(front/back). Označíme objekt a operaci zvolíme v menu (Modify>Arrange).

Pokud budeme chtít všechny objekty vlo�it do jedné jediné vrstvy, tedy sjednotit
všechny vrstvy, zvolíme menu Modify>Merge Layers.

Umístění objektů v jedné a ve více vrstvách

Inspektor Layers

Tento panel obsahuje veškeré informace o jednotlivých vrstvách. Zobrazuje vždy vrstvu
Web Layer a další vrstvy, které si může uživatel sám vytvořit a případně přejmenovat
poklepáním na jméno. Zápis vrstev je od nejnižší po nejvyšší a tahem je můžeme mezi
sebou přesouvat.
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Panel Layers organizující vrstvy dokumentu

Frames — filmové rámečky

Inspektor Frames (Window>Frames) úzce souvisí s inspektorem Layers. Je určen
především pro navrhování animací (viz kapitola Animace) a také pro vytváření tzv.
Rollovers — interaktivních tlačítek. Do každého rámečku můžeme vložit libovolný
objekt jako součást klasické dvourozměrné animace.

Panel Frames obsahující rámečky animace nebo tlačítek

Onion skin — je obdoba pauzovacího papíru pro snadnější navrhování animace bez
nutnosti neustále přepínat mezi jednotlivými rámečky. Lze zvolit (v pop-up menu
v levém dolním rohu) jaké další objekty z jiných rámečků budou v právě editovaném
rámečku viditelné, případně editovatelné (Multi-frame Editing).
Poklepáním na číslo prodlevy definujeme čas, po který bude rámeček zobrazen (v
setinách sekundy).

Všechny ostatní funkce fungují stejně jako u panelu Layers.
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Animace

Fireworks dovolují uživateli navrhovat a exportovat jednoduché animace ve formátu
animatedGIF. V podstatě se jedná o klasickou produkci dvojrozměrné animované
sekvence obrázek po obrázku (frame by frame). K tomuto účelu slouží inspektor
Frames. Ten obsahuje vždy jeden a více rámečků, do kterých zakreslujeme jednotlivé
fáze animace.

Animaci můžeme vytvářet několika způsoby.

Importované obrázky

Pokud jsme si již v minulosti nakreslili jednotlivé obrázky určené pro animaci do
rámečků (např. rozfázovaný pohyb človíčka) a uložili skrz menu Export
Special>Export As Files..., můžeme je nyní nahrát do Fireworks rovnou do jednotlivých
rámečků přes menu File>Open Multiple. V dialogovém okně zvolíme dvojklikem nebo
tlačítkem Add požadované soubory a potvrdíme stiskem Done.

Pomocí inspektora Frames dál upravíme rozestavení jednotlivých fází a výsledek
kontrolujeme animačními tlačítky na stavové liště v pravém dolním rohu obrazovky.

Symboly a instance

Pokud se rozhodneme nakreslit animaci, kde budeme objekty pouze pohybovat a
všechny jejich fáze budou stejné např. pohybující se text, použijeme symboly.
Symbolem může být libovolný grafický objekt a je chápán jako vzor pro jeho
„potomky“, tedy instance.
Symboly vytváříme a ukládáme do knihovny (Window>Library).

Knihovna obsahuje všechny symboly dokumentu
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Do knihovny dokumentu můžeme importovat objekty i z externích předdefinovaných
souborů skrze menu Insert>Libraries>....

Symbol vytvoříme tak, že označíme objekt a zvolíme menu Insert>Convert To Symbol.
Otevøe se dialog, kde budeme dotázáni na jméno a typ symbolu:
• Button — symbol „tlaèítko“, které obsahuje ètyøi fáze, tedy ètyøi rámeèky: Up,

Over, Down a While Down. Pøi editaci se ve spodním okraji lišty vypisuje nápovìda,
co do kterého rámeèku (panel Frames) nakreslit. Pøi budoucím vlo�ení symbolu do
dokumentu se nad tlaèítkem automaticky vytvoøí Slice (citlivá plocha — viz
Vytváøení Hotspots a Slice objektù), co� nám usnadní práci. Vytvoøený symbol
bude pak v prohlí�eèi animované tlaèítko.

• Graphics — normální grafický objekt, mù�e být i animací.

Pro editaci symbolu se v�dy otevøe nové okno, které po ukonèení mù�eme uzavøít.
Editujeme poklepáním na náhled symbolu nebo volbou menu knihovny (Edit Symbol).

Symbol můžeme vytvořit i zcela nový přímo volbou v knihovně nebo Insert>New
Button/Symbol....

Symbol sám o sobě nemá žádný význam. Je tedy nutné vytvořit jeho instance
(potomky), které budou jeho věrnou kopií:
• Přetažením symbolu z knihovny na plochu.
• Kopírováním, duplikováním nebo klonováním jiné instance (Edit>Copy/Paste,

Duplicate/ Clone)

Tweening — fázování pohybu

Pokud jsme tedy vytvořili symbol a jeho instanci, zbývá už jen malý kousek k vytvoření
plynulé animace.
• Vytvořme např. nápis ANIMACE, přeměňme ho na symbol a vytvořme alespoň dvě

jeho instance.
• Nyní označme tyto instance a zvolme menu Modify>Symbol>Tween Instances....

Otevře se dialogové okno, ve kterém zadáme počet fází (instancí) animace mezi
symbolem a instancí a zaškrtneme Distribute To Frames pro rozdělení fází do
rámečků. Pokud bychom nezaškrtli tuto volbu, nevytvořili bychom animaci, ale
pouze instance ve stejném rámečku animace. To bychom vyřešili označením všech a
volbou Distribute To Frames v panelu Frames.

Touto akcí vytvoříme nové instance rovnoměrně rozmístěné na pomyslné přímce mezi
symbolem a první instancí, automaticky zařazené do rámečků. A animace je na světě.
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Animovaný nápis, kde je každá následující instance vložena do následujícího rámečku

Složitější nebo komponovaný pohyb z jednoho místa na druhé a ze druhého na třetí
vytvoříme podobným způsobem. Stačí vložit více instancí a rozmístit je na klíčová
místa pohybu. Je nutné dbát na pořadí vkládáných instancí, protože Fireworks
rozeznávají pořadové číslo jednotlivých instancí a podle toho také výsledná animace
vypadá. Pak označíme všechny tyto instance s původním symbolem a v Tween Instance
dialogu nastavíme počet fází mezi jednotlivými klíčovými body. Animovaný objekt se
pak pohybuje po přímkách od symbolu k první instanci, ke druhé, třetí atd.

Funkce Tween Instance umí pracovat i se speciálními efekty:
• Vytvoříme symbol a jeho dvě instance.
• Pro první instanci nastavíme průhlednost (Opacity — inspektor Object) na 30% a

efekt (inspekor Effect) na Drop Shadow (vrhá stín) na 230°.
• Pro druhou pak průhlednost na 100% a efekt Drop Shadow na 30° a mírně ji

natočíme (Modify>Transform>Free Transform). Aplikujeme funkci Tween Instance
se šesti fázemi a výsledek je následující:

Tween Instance animace s použitím efektu (panel Effect)
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Z vlastností symbolů a instancí lze usoudit, že jsou vhodné nejen pro tvorbu animací,
ale také při kreslení obrázku se stejnými objekty, kdy se na každé instanci projeví
změna provedená na rodičovském symbolu.

Produkty pro internetové prostředí

Fireworks neoplývají pouze schopnostmi editovat vektorové nebo bitmapové obrázky a
exportovat je do souborů. Hlavní specialitou Fireworks je snadné vytváření tlačítek a
interaktivních „rozřezaných“ obrázků.
V této kapitole popíši, jak takové objekty vytvářet a exportovat do souborů pro další
použití.

Vytváření Hotspot a Slice objektů

Nejsilnější zbraní Fireworks je projektování interaktivních dokumentů, které je možné
rovnou vložit do internetové stránky, kde okamžitě fungují bez jakýchkoliv dalších
úprav a zásahů. Např. pokud připravujeme interaktivní mapu nebo menu tlačítek, stačí
si tlačítka pouze nakreslit rovnou vedle sebe jako jediný souvislý obrázek a ten pak
„rozřezat“ nástroji Hotspot nebo Slice, jednotlivým částem přiřadit funkce nebo odkazy
a exportovat jako skupinu souborů, kterou zakomponujeme přímo do stránky.

Nástroje Hotspot a Slice jsou tedy spíše velikým usnadněním při vytváření takových
specialit, které by bylo nutno složitě a nepřesně programovat v JavaScriptu a HTML
jazyce.

Slice
Slice znamená „rozřezat“ nebo „plátek“. Tímto nástrojem skutečně jakoby rozřezáváme
obrázek na obdélníky či čtverce, které do sebe navzájem zapadají. Jejich pužití je
zejména vhodné tehdy, pokud vytváříme např. tlačítková menu, tabulku zmenšených
obrázků (thumbnails) apod. Hlavně všude kde jsou podkladem pravoúhlé bitmapy a kde
je velká pravděpodobnost časté aktualizace nebo požadavek na různou kvalitu částí
podkladu. Pro takové účely je tento způsob interaktivity vhodný svou přehledností a
možností editovat např. jednotlivá tlačítka zvlášť, neboť na ty je v konečném důsledku
dokument rozřezán při exportu do souborů.

Vytvořme si pro lepší pochopení konkrétní obrázek dvou tlačítek v rámečku a
nakresleme nad každým zvlášť objekt Slice:
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Tlačítka v rámečku připravená k rozřezání do souborů 1—8  nástrojem Slice

Oba mají společná vodítka neboli slice guides (View>Slice Guides/Guide Options>Edit
Guides...), která naznačují rozřezání obrázku do jednotlivých souborů, barevně
zvýrazněnou citlivou interaktivní plochu a ovladače pro změnu velikosti. Volba
View>Slice Overlay umožňuje vytvářet i překrývající se slice-objekty.
Pokud bychom si chtěli usnadnit práci, tak je možné přímo na označený objekt
nakopírovat rozměrově přesný slice přes menu Insert>Slice.
Nyní si otevřeme panel Object, kde nadefinujeme atributy pro každý slice zvlášť.

Panel Object s atributy objektu Slice

Nakonec při samotném exportu dokumentu (viz Export dokumentu) je vygenerován
HTML soubor, který obsahuje kód pro sestavení jednotlivých obrázků dohromady a
přiřazení odkazů oboum tlačítkům.

Hotspot
Je varianta interaktivních obrázků, kterou obvykle používáme pro navrhování tzv. klik-
map nebo image-map, což jsou narozdíl od výsledků slice souvislé obrázky, jejichž
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některá, námi definovaná místa jsou citlivá na stisk myši v internetovém prohlížeči.
Jejich výhodou je efektní splynutí s podkladem a dokonalé kopírování požadované
oblasti. Tzn. že můžeme vytvořit tlačítka např. z domečku, kde dveře, okno i komín
budou odkazovat každý na jinou stránku viz obrázek.

Tvarová podobnost vzorových objektů a jejich Hotspots

Při kreslení hotspot objektů máme na výběr ze tří tvarů: Obdélník, Kruh, Polygon.
Navíc je možné na libovolný vyselektovaný objekt nakopírovat tvarově i rozměrově
přesný hotspot přes menu Insert>Hotspot.
Vytvořený objekt je možné také zvětšovat a upravovat pomocí ovladačů.

Panel Object je podobný objektu slice, je zde možné dodatečně změnit tvar
(Obdélník, Kruh, Polygon).

Panel Objects s atributy objektu Hotspot

Další možná nastavení Hotspot i Slice objektů lze provést v menu File>Document
Properties...
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Export dokumentu

Fireworks obsahují velmi detailní dialog exoportu dokumentu, kde je možné volit
z mnoha alternativ (File>Export Preview...). Slouží k uložení dokumentu do různých
formátů a generování pomocného JavaScript nebo HTML kódu pro snadné vkládání do
internetových stránek.

Dialog Export Preview pro nastavení atributů výsledného souboru

Součástí dialogu Export Preview jsou tři následující záložky.

Options — formát cílového souboru
Exportovat výslednou grafiku můžeme ve Fireworks do několika druhů formátu, který
vybíráme v prvním pop-up menu dialogu:

Format — formát cílového souboru (Gif, animatedGif, Jpeg, Png, Tif, BMP)
s příslušnou bitovou hloubkou (8, 24, 32)

Právě u indexovaných 8-bitových formátů můžeme experimentovat a dále upravovat
paletu barev:
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Záložka Options pro definování cílového formátu

Pro všechny formáty společně fungují volby:
Matte — nastavuje barvu nevyužitého nebo průhledného pozadí.
Export To Size Wizard — zde zadáváme požadovanou velikost souboru v kilobytech,
přičemž se Fireworks snaží této velikosti přiblížit na úkor kvality dokumentu.
Export Wizard — pomáhá nastavit export dialog formou otázek a odpovědí.

File — rozměry dokumentu
V této záložce nastavujeme rozměry obrázku, případně konkrétní exportované části.
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Záložka File Export dialogu

Animation — vlastnosti animace
Pokud v záložce Options zvolíme formát AnimatedGIF, můžeme v této záložce nastavit
vlastnosti celé animace, ale i jednotlivých rámečků.

Záložka Animation pro nastavení exportu animací

Disposal method — na výběr jsou čtyři metody překreslování animace
• Unspecified — nespecifikuje metodu, Fireworks automaticky zvolí překreslovací

metodu (nejmenší velikost souboru)
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• None — rámeček není odstraněn doku není překreslen jiným
• Restore To Background — překresluje rámeček barvou nebo vzorem pozadí

prohlížeče a poté vkládá nový, vhodné pro průhledné animace
• Restore To Previous — maže aktuální obrázek v rámečku a zobrazuje podkladový

obrázek předchozího rámečku, vhodné pro animaci nad obrázkem

Umístění dokumentu

Když vyplníme a nastavíme všechny volby Export dialogu, stiskneme tlačítko Export...,
která otevře exportní okno, kde zadáme název výsledného resp. výsledných souborů
projektu. Zvolíme zda chceme exportovat i slice a hotspot objekty (nesmíme
zapomenout pokud chceme exporotvat funkční tlačítka apod.), vrstvy nebo rámečky a
nastavíme formát doprovodných HTML souborů.

Po zadání všech atributů je možné potvrdit klávesou Uložit/Save, čímž je export
dokončen.

Panel Optimize

Pro rychlejší a o něco méně detailnější nastavení optimalizace exportovaného souboru
slouží panel Optimize (Window>Optimize). Je velmi podobný panelu Options přímo
v Export Preview dialogu. Pokud pro editovaný dokument nastavíme atributy exportu,
stačí pak už jenom zvolit File>Export... a soubor uložit rovnou do souboru.

Vlastní nastavení optimalizace je možné uložit, smazat a upravit v menu panelu.

Import dokumentu do existujících stránek
V některých případech např. při exportu hotspot nebo slice objektů, je uložen mezi
výsledné soubory i HTML soubor určený pro vložení do kódu naší stránky.

Pokud soubor exportujeme jako GenericHTML a otevřeme jej v textovém nebo
HTML editoru, zjistíme, že je přehledně rozdělen do JavaScript sekcí oddělených
nápisy „BEGIN COPYING THE JAVASCRIPT SECTION HERE“ a „STOP
COPYING THE JAVASCRIPT HERE“ a HTML sekcí s nápisy „BEGIN COPYING
THE TABLE HERE“ a „STOP COPYING THE TABLE HERE“.

Nakopírujeme je tedy do našeho existujícího HTML souboru. JavaScript sekci do
hlavičky souboru (mezi tagy <HEAD> a </HEAD>) a sekci HTML do těla souboru
(mezi tagy <BODY> a </BODY>).

To je vše. Pouze je nutné dbát na správné umístění souborů v adresářové struktuře.
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Pomocné panely

Protože jsou Fireworks se svými funkcemi a schopnostmi relativně rozsáhlé, obsahují
navíc pomocné prvky, které nám pomáhají snáze se orientovat a pracovat v takovém
členitém prostředí.

URL manažer — správce adres a odkazů

Tento panel (Window>URL) nám pomáhá vyznat se v desítkách různých internetových
adres, na které ve vlastní stránce (projektu) odkazujeme. Zapisujeme do něho své
adresy, můžeme vytvářet pro každý projekt vlastní URL knihovny, ty pak různě
editovat atd.

Panel URL spravující odkazy dokumentu

Pokud definujeme např. URL v panelu Object libovolného slice nebo hotspot objektu,
stačí po označení této položky poklepat v URL Manageru na požadovanou adresu a ta
bude automaticky přenesena do vlastností objektu.

Find & Replace — záměna hodnot

Velmi vhodný inspektor (Window>Find&Replace) rozhodneme-li se změnit hromadně
hodnotu Text, Font, Color (barva) nebo URL ve výběru (Selection), rámečku (Frame),
dokumentu (Document), v souborech uvedených v Project Log (viz následující
kapitola) nebo v libovolném PNG souboru. Stačí pouze správně zadat co, kde a čeho se
změna bude týkat a postupně procházet vyhledané změny tlačítkem Find Next a Replace
nebo rovnou změnit všechno tlačítkem Replace All.



Macromedia Fireworks 3

119

Panel Find and Replace určený k záměně hodnot v dokumentu

Project Log — soubory projektu

Pokud pracujeme delší dobu na rozsáhlejším projektu, kde současně editujeme několik
dokumentů, je vhodné vytvořit si přehled užívaných souborů v tomto panelu. Stačí
soubory do Project Log přidat a vytvořit tak na ně odkazy.

Project Log a Find & Replace spolu úzce souvisí, neboť všechny změny provedené
pomocí Find & Replace jsou spolu s časem zaznamenány do Project Log a my můžeme
tyto změny snadno kontrolovat.

Snadné je i otevírání souborů z tohoto panelu, stačí pouze poklepat na uvedený
dokument a ten se sám automaticky otevře bez nutnosti hledání v adresářové struktuře.
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Macromedia Dreamweaver 3

Macromedia Dreamweaver 3, program pro editaci internetových stránek, je velmi
užitečný nástroj určený jak pro začátečníky, tak i pokročilé tvůrce. Jeho nespornou
výhodou je vizuální výstavba stránky bez nutných rozsáhlých znalostí jazyků HTML,
DHTML, JavaScriptu apod., které jsou dnes běžným standardem při tvorbě WWW
dokumentů. To uživateli umožňuje soustředit se na obsahovou a vzhledovou stránku
věci s využitím mnoha efektních prvků, kterých docílí pouhým kliknutím myši.

Je samozřejmé, že pokud začneme pracovat s takovýmto editorem, je vhodné
proniknout alespoň do základů výstavby stránky za pomoci jazyka HTML.
Dreamweaver totiž umožňuje editovat dokument jak vizuálně vkládáním objektů, tak
přímo zasahovat do kódu skrze vestavěný textový editor.

Pracovní prostředí

Pracovní plocha Dreamweaveru 3 je obdobná jako u pøedchozích verzí. Hlavní okno je
velmi jednoduché, ihned po otevøení je úplnì prázdné pouze s øadou ikon pod hlavní
lištou, do kterého budu odkazovat na jednotlivé funkce (napø.: View>Rulers>Show).
Na této ploše probíhá návrh stránky a je zobrazován obvykle pøesnì tak, jak bude
vypadat v internetovém prohlí�eèi. Nástroje a veškeré ostatní ovladaèe dùle�ité pro
editaci jsou pro vìtší variabilitu prostøedí umístìny v samostatných menších oknech —
panelech.

Vzhled Macromedia Dreamweaver 3
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Na spodní stavové lištì hlavního okna (View>Status Bar) jsou neustále k dispozici
tlaèítka, kterými rychle otvíráme respektive zavíráme jednotlivé ovládací panely. Jejich
pøesuvnou kopii je mo�né otevøít i v menu (Window>Launcher). Hned vedle jsou
zobrazovány informace o velikosti vytváøeného dokumentu a velikosti editaèního okna,
které je mo�né nastavit manuálnì nebo vybrat z pøednastavených hodnot, co� je
vhodné pokud navrhujeme stránku pro konkrétní grafické rozlišení.

Na stejné lištì se zcela vlevo zobrazuje v�dy TAG (html pøíkaz) ze zdrojového kódu
stránky, který právì upravujeme.

Kolem pracovní plochy mù�ou být zobrazeny i pravítka pro orientaci ve vzdálenostech
(View>Rulers>Show), u nichž můžeme nastavit i jednotky zobrazení (View>Rulers>
Pixels/Centimeters/Inches) a tažením malého křížku v místě jejich křížení nastavit
jejich počátečbí bod. Ten resetujeme poklepáním na stejné místo nebo skrz menu
(View>Rulers>Reset Origin).

Pro přesnější umisťování objektů a textu do prostoru stránky je určena mřížka
(View>Grid>Show), na kterou se pøichytávají vkládané nebo pøesouvané objekty po
aktivaci funkce Snap To (View>Grid>Snap To). Vlastnosti mřížky nastavujeme v menu
View>Grid>Settings….

Pro samotnou editaci v Macromedia Dreamweaver 4, je velmi u�iteèný panel Objects
(Window>Objects), který obsahuje několik skupin ikon pro rychlé vkládání prvků do
navrhované stránky obvykle na aktuální pozici kurzoru.

Panel Objects obsahující seznam vkládaných objektů dělených do sekcí
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• Characters — Tlačítka pro vkládání jednotlivých symbolů v HTML kódu
zastoupených speciálním kódem &;

• Common — Tlačítka pro vkládání nejčastěji užívaných objektů
• Forms — Vkládání formulářů a jejich prvků
• Frames — Rozdělení stránky do rámů
• Head — Hlavièkové atributy dokumentu
• Invisible — Neviditelné prvky stránky (komentáøe, mezery atd.)

Dalším panelem pro rychlou editaci jednotlivých objektù jsou Properties
(Window>Properties), kde nastavujeme atributy vyselektovaného objektu. Ka�dý druh
objektu má k dispozici jiný obsah tohot panelu. Typickou souèástí je plocha základních
vlastností, rozšíøitelná šipkou v pravém dolním rohu. Šikovnou pomůckou je ikona pro
hledání cíle na disku, kterou vkládáme cestu k požadovanému souboru a „ukazovátko
na cíl“, které uchopíme a ukážeme přímo na cílový dokument (např. jiné otevřené okno
Dreamweaveru, nebo stránku zobrazenou v panelu Site (viz Organizace dokumentu).

Panel properties upravující atributy vybraného objektu

Pøed zaèátkem práce v Macromedia Dreamweaver 3 mù�eme zobrazit vlastnosti
programu v rozsáhlém dialogu Preferences (Edit>Preferences...), kde nastavujeme
vlastnosti, vzhled a chování editoru od obecných, přes definování externích editorů, až
po nastavení formátu HTML jazyka. Pokud si nebudete s některými volbami jisti,
obraťte se na podrobnou nápovědu (F1, Help>Using Dreamweaver).

Otevření dokumentu

Spustíme-li Dreamweaver, součástí jeho okna bude vždy plocha připravená pro editaci
nové internetové stránky. Můžeme tedy okamžitě začít pracovat.

Pokud ovšem chceme upravovat již existující stránku, je nutné ji nejprve otevřít, což
můžeme udělat několika způsoby:
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• Otevřít nový čistý dokument (File>New) — otevře se nové okno Dreamweaveru.
• Otevøít nový dokument podle šablony (File>New from template) — nabídnuty

jsou pøednastavené vzory (šablony), podle kterých mù�eme navrhovat novou
stránku (viz kapitolu Šablony)

• Otevøít existující dokument (File>Open…) — Dreamweaver 3 podporuje soubory
mnoha typù (napø. HTML,CSS,TXT,ASP…), ka�dý soubor je v�dy otevøen
v novém oknì editoru.

• Otevøít existující dokument do zvoleného rámu (File>Open In Frame) — do
rámu, ve kterém je umístìn kurzor se otevøe pøedem naeditovaná stránka, kterou je
mo�né také zvlášť editovat.

Pokud jsme otevøeli dokument, mù�eme se pustit do samotné editace stránky.

Uložení dokumentu

Ka�dý dokument je vhodné v prùbìhu práce postupnì ukládat. Je to dobré jak pro
kontrolu provádìnou testováním v prohlí�eèi, tak i pro bezpeènost naší práce.

• Ulo�ení dokumentu (File>Save)
• Uložení pod jiným jménem (File>Save As)
• Ulo�ení šablony (File>Save As Template...) viz kapitolu Šablony a knihovny
• Ulo�ení rámù viz kapitolu Rámy

Nastavení vlastností stránky
Jako první obvykle nastavujeme základní atributy vytvářené stránky (Modify>Page
Properties…).
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Page Properties — nastavení základních vlastností stránky

Pro každou stránku je vhodné nastavit základní barevné schéma, podle kterého se řídí
každý vizuální prohlížeč. Obsahuje základní barvu textu (Text), odkazu (Link),
navštíveného odkazu (Visited Link) a aktivního odkazu (Active Link). Kombinaci
těchto barev je možné navolit v předdefinovaných schématech v menu Commands>Set
Color Scheme....

Kontrola a editace HTML kódu

Dreamweaver 3 nám umožňuje kontrolovat a zasahovat do kódu dokumentu přímo
v prostředí programu.

HTML editor

Pokud chceme kontrolovat celý kód dokumentu a editovat na libovolném místě,
otevřeme HTML source inspektor volbou (Window>HTML Source), kde se
pohybujeme stejně jako v textovém editoru. Navíc si můžeme nastavit číslování (Line
Numbers)
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a lámání řádků (Wrap). Výhodou tohoto editoru je barevné rozlišování různých částí
dokumentu — HTML tagy, JavaScripty atd.

Vkládání HTML tagů

Další alternativou je vkládání pouze HTML tagů přímo v okně editovaného dokumentu.
Stačí kliknout na místo nebo objekt, kde chceme vložit nebo změnit tag a zvolit
Modify>Quick Tag Editor nebo v panelu properties stisknout stejnojmenné tlačítko
(zcela vpravo).

Otevře se malé okénko, ve kterém je buď tag, který dané místo obsahuje nebo
předepsané závorky, do kterých vpisujeme požadovaný kód tagu. Tyto závorky můžeme
smazat a vepsat i jiný kód.

Organizace dokumentu

Než začneme navrhovat novou stránku, je vhodné si navrhnou schéma stránky, tedy
počet stránek, jejich téma apod.

Nejprve si vždy vytvořme hlavní adresář na disku, do kterého budeme ukládat
všechny soubory navrhovaného projektu. Adresářovou strukturu stránky doporučuji
dodržovat, aby zůstala zachována návaznost odkazů a nemuseli jsme je později
předefinovat kvůli jiném umístění na serveru. Proto si vytváříme adresáře zvlášť na
obrázky, dokumenty, mediální soubory atd.

K takové organizaci slouží manažer Site (Site>Site Files/Site Map), kterým
zachováváme přehlednost projektu a zároveň můžeme „updatovat“ stránky na
vzdáleném počítači.

Definování odkazů

Pokud budeme vytvářet plnohodnotnou www stránku, jistě budeme používat odkazy,
kterými odkazujeme na další stránky projektu nebo zcela jiné.

Pro běžné vkládání odkazů slouží panel properties. Pouze označíme obrázek nebo
text, který chceme přeměnit na odkaz a vyplníme položku Link, což je adresa cílové
stránky. Případně najdeme cílový soubor v adresářové struktuře, označíme cíl pomocí
„ukazovátka na cíl“, jak bylo popsáno v kapitole Pracovní prostředí.

Pokud chceme nastavit cílové okno, ve kterém se požadovaná stránka otevře,
nastavíme také pložku Target následujícím způsobem:
• _blank — otevře stránku v novém okně
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• _parent — otevře stránku v rodičovském okně stránky s odkazem
• _self — otevře stránku ve stejném okně
• _top — otvírá stránku ve framesetu překrytím všech framů (viz Rámy)

Pokud vytváříme rámovou strukturu a pojmenujeme jednotlivá okna, názvy se budou
zobrazovat také v tomto menu. Vybereme-li jeden z nich, odkaz se otevře v konkrétním
rámu stejného okna (viz Rámy).

Formátování textu

Libovolný text můžeme vkládat psaním přímo do pracovní plochy stejně jako
v textových editorech. Potřebné funkce týkající se textu jsou umístěné v menu Text.
Jednotlivé vlastnosti z tohoto menu je možné nastavovat před samotným psaním, nebo
dodatečně aplikovat na označený text.

Editování textu je upraveno tak, aby případné námi nadbytečně napsané mezery nebo
tabulátory byly ignorovány a stránka tak byla zobrazována přesně tak jako v prohlížeči.
Je nutné podotknout, že stiskem ENTER začínáme editovat nový odstavec (Paragraph
— tag <P>).

Formátování HTML tagy

Tímto způsobem můžeme formátovat jednotlivá písmen, nebo celý text stránky
najednou. To provádíme pomocí panelu vlastností (Window>Properties). Stejné
nastavení provádíme skrze menu Text. Taková nastavení textu překrývají nastavení
HTML stylů a CSS stylů.

Panel properties pro text
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Formátování HTML styly

Dalším způsobem formátování textu stránky je využívání HTML stylů. HTML styl se
skládá z jednoho a více tagů, které jsou ukládány pro opakované použití v průběhu
textu.

Předdefinované styly jsou uloženy v panelu Window>HTML styles, odkud je
můžeme rychle aplikovat na jednotlivé odstavce (označením a následným kliknutím na
požadovaný styl). Naeditované styly jsou dostupné i v menu Text>HTML styles.

Nový styl (Text>HTML styles>New style...) definujeme skrze dialogové okno.

Panel HTML Styles pro definici stylů

Formátování CSS styly

Velmi efektním způsobem formátování textu, je aplikování CSS stylů, které předem
definujeme. Text definice je ukládán do hlavičky dokumentu mezi tagy <style
type="text/css"> a </style>. Třídy CSS stylů uchováváme a vybíráme v panelu
Window>CSS styles.

Panel CSS Styles pro definici stylù
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Libovolný styl můžeme aplikovat buď na vyselektovaný text (Selection), odstavec (tag
<P>) nebo na celé tělo stránky (tag <BODY>) vyselektováním a volbou Apply.

Pokud definujeme nový styl, vybíráme zda to bude vlastní třída (1 — v pop-up menu
zadáváme název třídy), pouze předefinováný HTML tag (2 — vybíráme tag
k předefinování) nebo styl selektování odkazů (3 — vybíráme stav odkazu, který
chceme předefinovat).

Tři varianty definice CSS stylu

Vždy se otevře rozsáhlý dialog, ve kterém definujeme do detailu vlastnosti nového
stylu.

Všechny styly užité v dokumentu je možné přehlédnout a editovat v okně Open Style
Sheet, což je tabulka užitých stylů, kde můžeme také připojit nebo přímo importovat
externí soubor stylů (tlačítko Link). To je vhodné při užívání stejných stylů ve více
stránkách.

Ty je možné poklepáním také dodatěčně editovat.
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Edit Style Sheet dialog spravující a definující všechny CSS styly dokumentu

Vkládání obrázků

Do HTML stránky vkládáme obrázky formátů JPG (fotografie), GIF (nápisy, tlačítka
atd.) a novější verze prohlížečů podporují i PNG formát, což je rozšířený formát
nahrazující GIF a užívaný editorem Macromedia Fireworks.

Obrázek vkládáme nastavením kurzoru a volbou menu (Insert>Image) nebo
stisknutím ikony Insert Image v panelu Objects — sekce Common.

Vlastnosti nastavujeme opět v panelu Properties po označení obrázku.
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Panel properties pro objekty Image (obrázky)

Rollovers — citlivé obrázky (tlačítka)

Obrázky citlivé na dotek kurzoru, kdy je původní obrázek nahrazen jiným adekvátním,
vytvoříme následujícím způsobem.

1.  Textový kurzor umístíme klimnutím na místo, kam chceme vložit rollover.
2.  Vložíme rollover volbou Insert>Rollover Image nebo kliknutím na ikonu Insert

Rollover Image v panelu Objects — sekce Common.
3.  V dialogu nastavíme atributy:

• Image Name — jméno obrázku
• Original Image — soubor původního nezměněného obrázku
• Rollover Image — soubor změněného obrázku po doteku kurzoru
• Preload Rollover Image — nahrává Rollover Image do paměti před/po doteku

kurzorem
• When Clicked... — nastavujeme odkaz takto vytvořeného tlačítka

4.  Potvrdíme stisknutím tlačítka OK.

Image maps — obrázkové mapy

Dreamweaver 3 umožňuje vytváření obrázků s citlivými oblastmi tzv. klikmapy.
Libovolná část obrázku může tedy reprezentovat odkaz na jinou stránku nebo objekt.
Takto můžeme nadefinovat libovolný obrázek zvlášť.
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1.  Vyselektujeme vložený obrázek.
2.  V panelu Properties zobrazíme kliknutím na malou šipku v pravém dolním rohu

rozšiřující  atributy.
3.  Do políčka Map zapíšeme jméno klikmapy, které musí být pro daný dokument

originální.
4.  Zvolíme jednu ze tří ikon Hotspot Tool (modré ikonky ve stejném panelu)

a nakreslíme na obrázek konkrétní citlivou oblast.
5.  Po jejím označení nastavíme vlastnosti v panelu Properties podle obrázku.

Panel properties s vlastnostmi objektu Hotspot

Do jednoho obrázku můžeme vložit libovolný počet takových citlivých ploch
opakováním kroků 4 a 5.

Pro vyselektování více oblastí najednou (např. pro jednotné nastavení) držíme
stisknutou klávesu SHIFT.

Vkládání tabulek

Tabulka HTML kódu obsahuje tři základní atributy:
• Řádky (Row)
• Sloupce (Column)
• Buňky (Cell)

Tabulky používáme pro přehledné uspořádání informací (dat) na stránce, nebo pro
efektní rozčlenění stránky bez potřeby užití rámců např. vkládáním tabulky do tabulky.
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Vložení tabulky

1.  Nastavíme kurzor na zvolené místo na stránce.
2.  Zvolíme Insert>Table nebo stiskneme tlačítko Insert Table v panelu Objects —

sekce Common.
3.  V otevřeném dialogu nastavíme potřebné atributy, které je možné změnit i dodatečně

v panelu Properties spolu s dalšími specifickými vlastnostmi.

Panel Properties s vlastnostmi tabulky

Při nastavení Border, CellSpace a CellPad se tabulka stává zcela neviditelnou.
Textová data a jiné objekty můžeme do tabulky vkládat ručně kliknutím do konkrétní

buňky a psaním nebo vložením objektu. Rozsáhlá data je ale také možné vkládat ze
souboru.

Vložení dat do tabulky ze souboru

1.  Existující tabulku si buď označíme, nebo pouze klikneme na požadované místo,
pokud chceme vytvořit rovnou tabulku novou.

2.  Stiskneme tlačítko Insert Tabular Data v panelu Objects — Common, nebo zvolíme
Insert>Tabular Data.

3.  Otevře se dialog pro Import dat:
• Data File — zdrojový soubor libovolného typu
• Delimiter — znak v textu, podle kterého budou data rozdělena do tabulky
• Table Width — šířka tabulky (Fit To Data — podle velikosti dat, Set — vlastní

nastavení v pixelech nebo procentuální šířka stránky nebo nadřazené tabulky
(rámu))

• Cell Padding — výška buněk
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• Cell Spacing — rozestup buněk
• Format Top Row — formátování první řádky jako nadpisu
• Border — šířka okrajů buňky

4.  Nastavení potvrdíme tlačítkem OK.

Řazení dat v tabulce

Každá obyčejně dělená tabulka obsahující textová data může být seřazena označením
a volbou Commands>Sort Table....

Další nastavení a editace tabulky

Libovolnou tabulku můžeme přesouvat kliknutím na její roh, čímž se označí, a
následným tahem. Stejným způsobem měníme rozměry tahem za jednotlivé ovladače
(čtverečky na hranách tabulky). Pokud máme problémy s označováním tabulky, stačí
pouze kliknout do libovolné buňky tabulky a zvolit Modify>Table>Select Table.

Kliknutím na hranu tabulky označujeme řádky resp. sloupce, jejichž obsah můžeme
libovolně přesouvat, mazat nebo kopírovat, stejně jako jednotlivé buňky. Označení více
sloupců/řádek provádíme s klávesou SHIFT. Tahem okrajů libovolné buňky měníme
její rozměry.

Klikneme-li do libovolné buňky, v panelu Properties nastavujeme její individuální
vlastnosti včetně dělení do více buňek a sjednocování.

Panel Properties pro editaci jednotlivých buněk

Detailní úpravy tabulky nastavujeme v menu Modify>Table>..., včetně odebírání
a přidávání řádek a sloupců (Insert/Delete — Row/Column). Označíme-li klikáním
a držením klávesy SHIFT více sousedících buněk a stiskneme tlačítko pro sloučení



Macromedia Dreamweaver 3

137

v panelu Properties, buňky splynou v jednu. Označíme-li jednu buňku a stiskneme
tlačítko pro rozdělení, budeme dotázáni, na kolik řádků/sloupců má být buňka
rozdělena.

Formátování tabulky podle předdefinovaných stylů

Dreamweaver 3 umožňuje formátovat tabulku podle předdefinovaných stylů. Stačí
označit tabulku a zvolit Modify>Format Table.... Otevřený dialog nabízí několik
formátů, které stačí zvolit aplikovat na tabulku stiskem OK. Každý styl však můžeme
ještě radikálně pozměnit nastavením jednotlivých atributů.

Vrstvy

Vrstva je obdélníkový námi nadefinovaný prostor, který je jednotnou samostatnou
plochou nad dokumentem. Obvykle je definována v HTML kódu tagy <DIV>
a <SPAN>, což jsou CSS-vrstvy použitelné v prohlížečích Iexplorer 4.0 a Netscape
Navigator 4.0 a výš, ale k dispozici jsou i tagy pouze pro prohlížeč Netscape, tedy
<LAYER> a <ILAYER>.

Do vrstev mù�eme vkládat libovolný obsah — text, obrázky, formuláøe a jiné
objekty. Pou�ívány bývají pro pøesné ukládání objektù na obrazovku, pro pøekrývání
objektù a další speciální efekty. Vrstvy nerespektují �ádná ohranièení (kromì hranic
rámù) a mohou být umístìny na libovolném místì.

Základní vlastnosti vrstvy jsou left (souøadnice X levého horního rohu), top
(souøadnice Y levého horního rohu) a z-index, co� je poøadí, nebo� se vrstvy mohou
pøekrývat.

Znázornìní pøekrývání vrstev
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Novou vrstvu vytvoøíme zvolením tlaèítka Draw Layer v panelu Objects — common
a následným nakreslením ohranièení vrstvy stejnì, jako pøi kreslení obdélníku
v grafickém editoru. Rozmìry pak mìníme oznaèením (kliknutím na ètvercovou
zálo�ku v levém horním rohu) a tahem za ètvercové ovladaèe, nebo je mìníme
numericky v panelu Properties s dalšími vlastnostmi.

Vlastnosti vyselektované CSS a Netscape vrstvy

Vrstvy mù�eme vkládat i do sebe, kdy� novou vrstvu vytvoøíme tak, �e nejprve
oznaèíme vrstvu rodièovskou a do její zálo�ky pøetáhneme ikonu Draw Layer v panelu
Objects. Takové ikony jsou pak sdru�ené, dceøiné dìdí (Inherit) viditelnost a pohybují
se pokud pohybujeme vrstvou rodièovskou.

Ka�dé vrstvì mù�eme nadefinovat viditelnou plochu atributy L,T,R a B, kde L a T
jsou souøadnice levého horního a R a B pravého dolního rohu viditelné oblasti.
Souøadnice jsou poèítány od levého horního rohu vrstvy (0,0).

Pro CSS vrstvy (DIV a SPAN) mù�eme nastavit zobrazování obsahu vrstvy —
Overflow:
• Visible — Velikost vrstvy se pøizpùsobuje obsahu.
• Hidden — Obsah pøesahující velikost vrstvy je ignorován a nezobrazován.
• Scroll — Pøidává v�dy scrollbary (posuvníky) na okraje vrstvy.
• Auto — Posuvníky se zobrazují pouze je-li obsah vìtší ne� vrstva.
Pro Netscape vrstvy (LAYER a ILAYER) navíc mù�eme nastavit adresu dokumentu
(atribut Src), který bude ve vrstvì zobrazen (obsah není v editoru zobrazován). Další
odlišností je mo�nost definování místo z-indexu pøímo název, nad (Above) nebo pod
(Below) kterou bude zvolená vrstva umístìna (atribut A/B).
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Organizace vrstev

Všechny vytvoøené vrstvy jsou zaznamenány pod svým jménem (implicitnì jsou
generována jména Layer 1, Layer 2 atd.) v panelu vrstev (Window>Layers), kde je
mù�eme pøejmenovávat (poklepáním), organizovat (tahem) a mìnit individuální z-
index, kterým definujeme poøadí vrstev nebo-li pøekrývání — èím vìtší èíslo, tím výše
bude vrstva ulo�ena a tedy nepøekryta jinou vrstvou.

Panel Layers organizující vrstvy dokumentu

Tlaèítko Prevent Overlaps zabraòuje pøekrývání vrstev, nebo� pokud se rozhodneme
pøevést vrstvy na tabulku, nebudou pøevedeny ve správné poloze pokud se budou
zakrývat.

Vkládání objektů do vrstvy

Do vrstvy mù�eme vlo�it libovolný objekt. Staèí pouze vrstvu oznaèit kliknutím do
jejího tìla a následnì vlo�it text, obrázek, klip atd.

Vrstvy a tabulky

Na vrstvy se mù�eme také dívat jako na tabulku o jedné buòce. Proto je mo�né
pøevádìt existující tabulku na vrstvy, kde ka�dá buòka bude jedna vrstva. Oznaèíme
tabulku a zvolíme Modify>Layout Mode>Convert Table To Layers.... Označením více
vrstev (podržením klávesy SHIFT) a volbou Convert Layers To Table... můžeme
převést vrstvy zpět na tabulku.
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Tohoto principu se využívá např. tehdy, když stránku efektně rozvrhneme pomocí
vrstev a pak ji pro větší kompatibilitu se staršími prohlížeči, které nepodporují vrstvy,
převedeme na systém tabulek.

Vrstvy, obrázky a DHTML

V Macromedia Dreamweaveru 3 můžeme s vrstvami a obrázky dále pracovat pomocí
dynamického HTML. Při návrhu netradičních a efektních prvků, jakými jsou proměny
pozice vrstvy či obrázku v čase (tedy jednoduché animace), používáme časových os. Ty
jsou přehledně zobrazovány v panelu Timelines (Window>Timelines).

Panel Timelines pro konstrukci animací vrstev a obrázků

Funkce menu panelu Timeline:
• Add KeyFrame — přidá klíčový rámeček na místo ukazatele (pouze v nich mohou

být definovány změny umístění)
• Remove KeyFrame — odstraní klíčový rámeček
• Change Object — změní animovaný objekt za jiný
• Add Object — přidá objekt do animované osy
• Remove Object — odstraní objekt z osy
• Record Path of Layer — nahrává ručně vedený pohyb vrstvy
• Add Behavior — přidá položku chování (událost — akce) do osy B
• Remove Behavior — odstraní položku chování
• Add Frame — přidá rámeček
• Remove Frame — odstraní rámeček
• Add Timeline — vytvoří novou časovou osu
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• Remove Timeline — odstraní osu
• Rename Timeline — přejmenuje časovou osu

Můžeme vytvářet víc časových os, různě je pojmenovávat a vkládat do nich objekty,
jejichž čas pak dále upravovat (viz menu panelu nebo Modify>Timeline>...) a do řádky
B (Behaviors) nastavovat akce, které se provedou po dosažení konkrétního rámečku.

K přehrávání časových os potom slouží akce Timeline>Play/Stop Timeline v panelu
Behaviors. Ty pak můžeme přidat např. libovolnému tlačítku a přehrát tak Timeline
animaci po stisknutí tlačítka atd.

Zajímavou animací je pohyb vrstvy resp. obrázku po předkreslené cestě (křivce), zde je
postup jak tento efekt snadno vytvořit:
1.  Vytvoříme si libovolnou vrstvu s obsahem textu nebo obrázku.
2.  Otevřeme panel Timelines (Window>Timelines)
3.  Označíme vrstvu klepnutím na její záložku.
4.  Zvolíme Modify>Timelines>Record Path of Layer.
5.  Uchopíme vrstvu a pohybujeme s ní podle toho, jak chceme, aby výsledná animace

vypadala.
6.  Uvolníme tlačítko myši v místě, kde chceme animaci ukončit. Do panelu Timelines

se vloží animace.
7.  Pomocí tlačítek přesunu po rámečkách si animaci přehrajeme, nebo nadefinujeme

tlačítku chování (Behavior), kterým animaci spustíme např. označením a kódem
OnMouseDown — PlayTimeline.

8.  Dokument uložíme a zkontrolujeme funkčnost v prohlížeči — vrstva by se měla začít
pohybovat po stisknutí nadefinovaného tlačítka přesně po předkreslené křivce.

S časovými osami můžeme vytvářet velké množství zajímavých efektů. Je pouze
otázkou zkušeností, jaké prvky budeme schopni generovat.

Rámy

Každou stránku můžeme rozdělit do libovolného počtu rámů. Užívají se především
k rozdělení stránky na logické celky, kde v každém rámu může být otevřena jiná
stránka. Dokument, který obshuje dělení do rámů je ukládán jako jeden soubor a obsahy
jednotlivých rámů jsou další samostatné soubory.
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Dělení Frameset na Frame

Každá rozdělená stránka obsahuje jeden a více předpisů dělení tzv. Frameset, které
obsahují jeden a více rámů — Frame. Obvykle se však používá pouze dělení s jedním
Framesetem.

Rozdělení dokumentu do Framesetu 1 s Framy 1, 2 a 3 a Framesetu 2 s Framy 4 a 5

K členění slouží menu Insert>Frames>...(dìlí frameset na framy), Modify>Frameset...
(vytváøí nové pøedpisy — framesety) a sekce Frames v panelu Objects, kde jsou
pøeddefinovaná rozdìlení.

Po vlo�ení rámu je mo�né okraji pohybovat tahem a zmenšovat resp. zvìtšovat jeho
velikost. Do ka�dého rámu mù�eme vlo�it další rámové èlenìní.

Pro kontrolu a editaci framů a framesetů slouží panel Window>Frames, kde se mezi
rámy přepínáme a skrze panel Properties nastavujeme jejich vlastnosti.

Vlastnosti Framu
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Vlastnosti Framesetu

Ukládání Frameset a Frame

Soubor, ve kterém je uloženo rozdělení stránky na rámy, tedy Frameset ukládáme
volbami File>Save Frameset/Save Frameset As.... Obsah jednotlivých rámů uložíme
kliknutím do plochy konkrétní části a volbou File>Save/Save As.... Všechno najednou
ukládáme File>Save All.

Editace verze stránky bez rámců

Pokud vytvoříme stránku rozdělenou do rámců, můžeme také vytvořit jako součást
dokumentu variantu bez rámců, která bude automaticky zobrazována textovými nebo
staršími prohlížeči nepodporujícími rámy.

Zvolíme Modify>Frameset>Edit NoFrames Content a editujeme „bezrámovou“
variantu. Editaci ukonèíme stejnou volbou.

Výsledný HTML kód bude souèástí pùvodního dokumentu a bude uzavøen mezi
tagy <NOFRAMES> a </NOFRAMES>.

Vkládání médií

V Dreamweaveru můžeme do dokumentu pohodlně a efektně vkládat mediální prvky
vytvořené v externích editorech. Na výběr jsou soubory s Java applety, Flash
a ShockWave animacemi, ActiveX a další objekty podobného typu.

Pro všechny platí, že stačí nastavit kurzor na požadované místo na stránce a vložit
mediální soubor volbou Insert>Media>... nebo pøímo kliknout na konkrétní tlaèítko
v panelu Objects — sekce Common. Obvykle se otevøe okno, kde vybíráme zdrojový
soubor objektu.
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Panel Objects — Common s ikonami pro vkládání médií

Pro ka�dý takto vlo�ený objekt mù�eme dodateènì nastavit obecné atributy. Staèí na
objekt kliknout pravým tlaèítkem a z menu zvolit potøebné údaje, jako je jméno objektu
(Name), zdrojový soubor (Source File), parametery (Parameters), alternativní obrázek
(Alt Image), umístìní (Align) atd.

Detailní nastavení provádíme pro ka�dý objekt v panelu Properties.
Pro vkládání tìchto souborù do HTML kódu, pou�ívá Dreamweaver tagy

<OBJECT>, <EMBED> a případně <APPLET>.

 
Vkládání Flash a Shockwave animace

Mediální soubory Flash (Macromedia Flash) a ShockWave (Macromedia Director) jsou
si velmi podobné a proto i jejich nastavení je témìø toto�né. Po vlo�ení tìchto objektù
otevøeme panel Properties, kde nastavíme vlastnosti podle potøeby.

Vlastnosti vlo�eného objektù Flash a Shockwave
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V nastavení Shockwave nenajdeme pouze položky Quality, Scale, Loop a Autoplay,
nebo� tìmito mìnitelnými atributy nedisponuje.

Vkládání objektu Generátor

Macromedia Generator pro ovládání dynamických stránek vkládáme stejně jako ostatní
mediální objekty. Při vkládání je zobrazován dialog, ve kterém volíme šablonu
(template) Generatoru (.swt — tu je možné vytvořit v Macromedia Flash 4 a výš) a typ
její reprezentace (Type — SWF, JPEG, GIF, MOV, PNG), podle které se bude
Generator chovat.

Můžeme přidat/odebrat parametry typu jméno=hodnota tlačítky (+/-), ovlivňující
funkci Generatoru.

Podle nastaveného typu generátoru se celý objekt chová a disponuje stejnými
atributy v panelu Properties jako zvolený typ.

Vkládání Netscape pluginu

Pluginy rozšiřují schopnosti Netscape Navigatoru o přehrávání mediálních souborů
různých formátů. Pokud tedy vytvoříme soubor pro konkrétní plugin, můžeme ho skrz
Dreamweaver lehce vložit do naší stránky.

Měnitelné vlastnosti plugin souboru jsou následující:

Vlastnosti vloženého objektu Netscape plugin
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Vkládání ActiveX

ActiveX je spíše znám pod označením OLE, což jsou miniaturní aplikace, které fungují
podobně jako plugin. Jsou ale určeny pouze pro prohlížeč Iexplorer pro systém
Windows, ne však pro Netscape Navigator a platformu Macintosh. Vložený objekt
ActiveX nám umožní aplikovat nastavení těchto ovladačů ve vzdáleném  prohlížeči
návštěvníka.

Nastavitelné jsou následující atributy:

Vlastnosti objektu ActiveX

Tag EMBED volíme tehdy, pokud máme k dispozici adekvátní Netscape plugin, který
by zastoupil příslušný AX ovladač v prohlížeči Netscape. Potom zadáváme zdrojový
soubor i pro plugin. Alternativní obrázek je zadáván v opačném případě, chceme-li
alespoň v prohlížeči Netscape zobrazit momentku z případného klipu apod..

Vkládání Java appletu

Applet vkládáme do dokumentu ze souboru stejně jako ostatní objekty. V panelu
properties jsou k dispozici kromě základních parametry CODE a CODEBASE pro
název zdrojového souboru a adresu jeho umístění.

Přehrávání mediálních objektů v Dreamweaveru

Pokud si chceme zkontrolovat průběh a správnou funkčnost a nastavení jednotlivých
mediálních objektů (Shockwave, Flash, Plugin), můžeme tak učinit přímo v panelu
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properties kliknutím na zelenou šipku, nebo volbou View>Plugins>Play/Stop. Pro
přehrávání všech umístěných pluginů slouží volba View>Plugins>Play/Stop All.

Nastavení chování objektů — Behaviors

V Dreamweaveru můžeme dosáhnout velmi rychle a relativně snadno dobrých efektů
v interaktivitě stránky. Toho docílíme definování „chování“ stránky, tedy Behavior, což
je kombinace události (event) a akce (action). Např. pokud přejedeme kurzorem myši
přes obrázek (událost), začne se přehrávat Flash animace (akce).

Události jsou generovány prohlížečem návštěvníka jako volání funkce a jsou
předávány akcím, které jsou v HTML kódu stránky reprezentovány funkcemi
JavaScriptu. Nevýhodou však je, že každý prohlížeč, tedy hlavně Iexplorer a Netscape
Navigator, jakožto konkurenční produkty, nepodporují všechny události. Proto je
obvykle vhodné používat funkce událostí takové, které jsou podporovány oběma
prohlížeči.

Behavior inspektor

Vkládání a nastavování událostí probíhá v panelu Behavior (Window>Behaviors), kde
jsou pro každý označený objekt zvlášť zobrazována nastavená chování.

Inspektor Behavior pro definování chování objektů

Definování chování
1.  Nejprve si vždy označíme objekt, pro který chceme nadefinovat nové chování (např.

obrázek).
2.  Tlačítkem (+) nejprve volíme akci, která bude provedena po určité události

provedené na zvoleném objektu.
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3.  Poté se otevře dialog, ve kterém nastavujeme atributy akce (např. pro Play Sound
volíme zdrojový soubor zvuku).

4.  Potvrzením OK se uloží položka chování do seznamu a bude dostupná vždy po
označení toho konkrétního objektu, pro který jsme chování definovali.

5.  Kliknutím na položku se zobrazí šipka (pop-up menu), kterým volíme příslušnou
akci pro danou událost (např. On Click — pro kliknutí myší na objekt)

6.  V pop-up menu Events For nastavujeme typ prohlížeče, ve kterém by funkce chování
měla pracovat.

7.  Dvojklikem na položku chování můžeme znovu předefnovat vlastnosti dané akce.

Po nadefinování chování se do zdrojového kódu dokumentu vloží příslušný kód události
v JavaScriptu umístěný mezi tagy <SCRIPT LANGUAGE="JavaScript">
a </SCRIPT>.

Rozšíření vestavěných akcí
Vestavìné akce nabízené v panelu Behaviors je mo�né dále rozšíøit. Staèí pouze
kliknout na tlaèítko (+) pro pøidání polo�ky do seznamu a zvolit polo�ku Get More
Behaviors..., nebo se pøímo obrátit na stránky firmy Macromedia
(www.macromedia.com), kde se mù�eme bezplatnì zaregistrovat a získat tak pøístup
k mnoha dalším a originálním freewarovým extensions (rozšíøením).
Pøedprogramované akce velmi usnadòují tvorbu www stránek bez nutnosti slo�itého
programování JavaScriptù apod.

Šablony a knihovna

Šablony a knihovny nám mohou pomoci při vytváření webových stránek s jednotným
designem. S jejich pomocí je velmi jednoduché snadno a rychle měnit hromadně design
desítek stránek pouze rychlou změnou šablony nebo knihovny.

Šablony

Šablony používáme jako základ pro všechny ostatní stránky projektu. Proto při návrhu
šablony rovnou volíme, které prvky budou měnitelné (text, individuální obrázky apod.)
a které budou konstantní pro všechny ostatní stránky (záhlaví, pozadí atd.). Např. pokud
vytváříme jednotlivé stránky ceníku, kde budeme měnit pouze název, obrázek a cenu
produktu, vytvoříme šablonu, která bude mít editovatelné pouze tyto tři položky.
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Vytvoření šablony
• Ulo�ením stávajícího dokumentu jako šablony (File>Save As Template...)
• Založením zcela nové šablony (v panelu Template tlačítkem New Template)

Organizace a editace šablon
Šablony dokumentu jsou uchovávány v panelu Templates (Window>Templates).

Panel Templates sdru�ující vytvoøené šablony

Pokud poklepeme na jmenovku šablony, nebo stiskneme ikonu Open Template
v pravém dolním rohu panelu, otevřeme nové okno, ve kterém můžeme šablonu
editovat.

Vytváříme ji v podstatě stejně jako normální dokument, pouze navíc označujeme
editovatelné plochy a objekty, aby šablona měla význam při rychlé editaci odvozené
stránky. Každé editovatelné místo v šabloně je pojmenováno.

Plochu pro volnou editaci označíme kliknutím na zvolené místo a volbou
Modify>Templates>New Editable Region.

Objekt určený ke změně označíme a přeměníme na editovatelnou položku volbou
Mark Selection As Editable. Při vytváření je nutné vždy zadat jasné a pochopitelné
jméno oblasti, neboť bude zobrazeno při editaci odvozených stránek.

Volbou Unmark Editable Region ruší oblast, kterou vybereme ze seznamu.

Mezi editovatelnými oblastmi se pøepínáme kliknutím, nebo zvolením konkrétního
jména v menu Modify>Templates>....

Aplikace šablony
Chceme-li podle šablony vytvoøit novou stránku, zvolíme File>New From Template
a mù�eme rovnou zaèít upravovat dokument vkládáním objektù a textu. Dreamweaver
nás nenechá zasáhnout nikam jinam ne� do pøedepsaných oblastí. Dokument pak
bì�nì ulo�íme a mù�eme zaèít s editací další stránky.
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Šablonu lze aplikovat na ji� existující editovanou stránku, ale tento zpùsob pøíliš
nedoporuèuji, nebo� Dreamweaver nerozdìluje obsah stránky pøesnì do po�adovaných
kolonek (Modify>Templates>Apply Template To Page).

Knihovna

Knihovna dokumentu (Window>Library) sdružuje objekty (obrázky, nadpisy, text,
tabulky atd.), které se vyskytují ve více jak jedné stránce a je proto vhodné je pouze
distribuovat z knihovny na určená místa.

Knihovna (Library) se seznamem symbolů

Objekt do knihovny přidáme jeho označením a volbou New Library Item v menu
panelu, nebo Modify>Library>Add Object To Library. Objekt se označí žlutým
podkladem, stejně jako needitovatelná oblast šablony a dále už s ním nebudeme moci
pracovat jako s běžnou součástí stránky.

Jediný způsob jak objekt upravit je poklepat na jeho jmenovku v panelu Library,
nebo stisknout tlačítko Open Library Item v pravém dolním rohu. Otevře se samostatné
okno, ve kterém editujeme pouze zvolený objekt.

Pokud položku knihovny upravíme, je nutné provést „update“ všech instancí vložených
do ostatních stránek projektu. To provedeme volbou Update Current Page (obnova této
stránky) a Update Pages... (obnova všech ostatních stránek projektu) v menu panelu
Library.

Prvek z knihovny vkládáme do dokumentu přetažením jmenovky, nebo označením
a volbou Add To Page opět v menu panelu.
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Formulář

Formuláøe pou�íváme, jak je všeobecnì známo, k získávání informací od návštìvníkù
webové stránky. Ke správné funkci je zapotøebí vytvoøit pro návštìvníka vizuální
podobu formuláøe a pro server pak script, který bude umìt poøízená data spracovávat.

S pomocí Dreamweaveru 3 jsme schopni vytváøet pouze vizuální èást formuláøe,
tedy výbìrová (radial), zaškrtávací (checkbox), textová políèka, tlaèítka atd.

Vkládání formuláře

K vytvoøení formuláøe slou�í tlaèítka v panelu Objects — Forms.

Panel Objects — Forms s ikonami prvkù formuláøe

Podklad formuláøe (HTML podstatu ve formì tagu FORM) vlo�íme do stránky ikonou
Insert Form. Samotné prvky vkládáme pomocí dalších popsaných tlaèítek. Ka�dý má
své vlastnosti nastavitelné v panelu Properties a je velmi dùle�ité orientovat se alespoò
v základech vytváøení formuláøù a jejich cílových scriptù.

Poslední dùle�itým prvkem formuláøe je vlo�ení odesílacího tlaèítka, kterým vlo�ená
data u�ivatel odešle na server s cílovým scriptem (Insert Button). V menu Properties
opìt nastavujeme vlastnosti tlaèítka vèetnì funkce (SubmitForm — odesílá, ResetForm
— vymazává formuláø) a jmenovky.
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Kontrola dokumentu

V prùbìhu práce nebo na závìr mù�eme provádìt kontrolu vzhledu a funkènosti stránky
pøímo v internetovém prohlí�eèi. Pro rychlé pøepínání bez nutnosti ukládání souboru
je v Macromedia Dreamweaver 3 vytváøen seznam nainstalovaných prohlí�eèù
(File>Preview In Browser>Edit Browser List...). Zde bývá buď automaticky detekován
nebo manuálně přidán prohlížeč, ve kterém chceme stránku testovat. Nadefinovaný
seznam prohlížečů se nám pak zobrazuje ve stejném menu (File>Preview In
Browser>...) a my si pouze vybíráme, který chceme pro kontrolu spustit.

Pøed definitivním ulo�ením nebo pøed publikováním stránky na internetu, je vhodné
provést také kontrolu kódu. Volbou File>Check Target Browsers se otevře dialog, ve
kterém vybereme verzi prohlížeče (s klávesou CTRL i více), pro který chceme kód
dokumentu testovat. Po potvrzení výběru Dreamweaver provede kontrolu a případná
chybová nebo varovná hlášení vypíše přehledně v internetovém prohlížeči.

Pokud si nejsme jisti, že stránku nenavštíví někdo se starším prohlížečem, můžeme
provést konverzi kódu na starší verzi volbou Converse>Browser 3.0 Compatible.

Poslední pomocnou kontrolou nám mù�e být monitoring odkazù (linkù)
nadefinovaných v dokumentu (File>Check Links).
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Závěr
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Použité zdroje


